Cannot delete virtual server

Hi there,

I don’t know how this happened, but two vurtual servers have been created on my system. They are very strange. In the left menu, they appear as “128117018631484” and “128117018631315” (looks like strange date-formats from procmail). They don’t have any domain name, users, home directory whatsoever associated with them. The only service active is “mail”.

What’s even stranger, I can’t delete them. When I try, I get a “Domain (blah) is not valid!” error.

Okay, so what can I do from here? Is there a way to manually delete these from Virtualmin’s database?

Thanks in advance


That sounds like a bug of some sort… do you have any idea when they were created? One way to determine that would be to go into Edit Virtual Server, and look at the “Created On” field.

When you see that time/date, can you think of anything unusual that occurred around then?


Virtual server details
Domain name
Administration username
Created on 07/Aug/2010 10:35 by root
Home directory

That was this morning and I was logged in, but cannot think of anything unusual that happened.

Now this is annoying because as these are numeric entries, they appear first in the servers list, so I keep bumping on them. I disabled them just in case, but I’d relly like to delete them. Is there any way I can manually alter VM’s database in order to remove them?

Thanks in advance…

Bump. It’s been two weeks and this topic seems dead. Andrei (or anybody else), I really need some help on this one ! Please tell me how to remove the ghost servers from the list, please !

Bump again.

Please. Don’t let me down on this.
I need to make these servers go away.

Could you please walk me through manual deletion of these corrupted/invalid servers?
Please, some reply…

I’m having the same problem. Is there a fix or workaround for this?

Thanks in advance.

That seems to be a bug that shows up occasionally, though it’s not reliably reproducible, so it hasn’t been corrected.

The fix is simple though, you can delete the domain ID in “/etc/webmin/virtual-server/domains/”, restart Virtualmin, and then it should be gone from your drop-down list.


That’s worked. Many thanks for the prompt reply.

Hi guys,
I’m sorry to resurrect this post, but I had the same problem this morning.

If it can help. The date of creation of the virtual host is about the same as the end of a scheduled backup.
Maybe the bug is in the backup module.

Just to let you know I saw this exact same thing happen.

I agree with dalfiume in regards to the timing and scheduled backup…

What also happened with me was the accumulated backups kept increasing massively in size to a point that it filled the enter hard drive…

It filled the harddrive with several .tar.gz files, finally over 900 GB (!), until hard drive was full. … So any idea, how to make sure, this doesn’t happen anymore would be great.