Cannot create new server - quota issue?!


I´m having issues when I try to create a new virtual server. I receive the following error message:
Creating administration group testadmin …
… done
Creating administration user testadmin …
… done

Failed to create virtual server : setquota: Not all specified mountpoints are using quota.

Here´s my /etc/fstab: /dev/xvda1 / ext3 defaults 1 1 /dev/xvda2 none swap sw /dev/vg00/usr /usr ext4 errors=remount-ro 0 2 /dev/vg00/var /var ext4 errors=remount-ro,usrquota 0 2 /dev/vg00/home /home ext4 errors=remount-ro,usrquota,rw 0 2 proc /proc proc nodev,noexec,nosuid 0 0

Here´s my /etc/mtab:
/dev/xvda1 / ext3 rw 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
sysfs /sys sysfs rw,noexec,nosuid,nodev 0 0
none /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
udev /dev devtmpfs rw,mode=0755 0 0
devpts /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
tmpfs /run tmpfs rw,noexec,nosuid,size=10%,mode=0755 0 0
none /run/lock tmpfs rw,noexec,nosuid,nodev,size=5242880 0 0
none /run/shm tmpfs rw,nosuid,nodev 0 0
/dev/mapper/vg00-usr /usr ext4 rw,errors=remount-ro 0 0
/dev/mapper/vg00-var /var ext4 rw,errors=remount-ro,usrquota 0 0
/dev/mapper/vg00-home /home ext4 rw,errors=remount-ro,usrquota 0 0
none /proc/xen xenfs rw 0 0

I´m starting to get nervous, since I need to create some more hosts, and everybody is chasing me on that. Maybe one of you gurus does find what´s going wrong here? I just don´t get it…



Hmm, do you have a /dev/root device? I’ve sometimes seen what you’re describing when that doesn’t exist.

It should be a symlink, that points to the device where your root filesystem is mounted… /dev/xvda1 in your case.

You could fix that with these two commands:

ln -s /dev/xvda1 /dev/root /etc/init.d/quota start


this is since a long time a resolution of an error i do not understand…can you describe why this happened?

btw - removing my traces of previous trial and error sessions and applying your fix did the trick! thanks a ton, i was really looking for a solution for a couple of days (not fulltime, but again and again)…

I owe you a beer! :slight_smile:

Best Regards

Well, I don’t know why exactly that’s the case – but I’ve seen in some instances that on Xen-based systems, they don’t automatically setup a /dev/root symlink. It rarely seems to matter, except in the case of setting up quotas.