Cannot change IP with my vritual host

Hi all,

I am a newbie here. I am using virutalmin 3.5.7.gpl. Just want to ask a simple question that I cannot figure out by myself…

The problem is: I have a virtual serve created using virtualmin and a private IP allocated to it during the creation. Now I want to change the private IP to another one which is available for me and not been used by my other virtual servers currenly. However, when I click "Server Configuration" -> "Change IP Address" and input my new IP address, virtualmin showed me an error which said "Failed to change IP address : The new address is already in use by the system".

I only have 2 virtual servers online, and I have 5 IP available. Through virutalmin “System Informaion” -> “IP Address Allocation”, I don’t see my new IP address so I am sure it is not used by my server.

Another interesting thing is, if I choose to create a new virtual server via virtualmin, then this new IP could be used as I choose "Virual with IP (Already Active)".

Any ideas about this issue would be very appreciated. Thanks in advance!

I am not sure exactly but if you did not create a virtual eth for that IP then it’s active on the default eth. I don’t know this for a fact though.

I think you need to create a virtual eth0:1 under eth0:0 and dedicate that new IP to it. I’ve set up 2 IP’s like this used for NS records.

webmin-networking-network configuration-network interfaces-click on eth0:0 - Virtual interfaces (Add virtual interface)-click on add virtual interface and fill in the info.

you should then be able to dedicate a domain to that eth0:1 with that IP.

the other thing might be to change the address in the virtualmin-addresses and networking-change IP address and change what you need to change.

Dear ronald,

Thanks for your reply!

However, I checked my network interfaces status through webmin and found that my new IP address has already been dedicated to a virtual eth which is venet0:1. And my network interfaces status for this 2 IP address is listed below:

Name Type IP Address Netmask Activate at boot?

venet0:0 Unknown (Virtualmin Virtual Servers (GPL)) Yes

venet0:1 Unknown (Virtual) Yes

All I want to do is to use instead of as my virtual server’s new IP address.

Please let me know if you have any new ideas. Thanks very much for your help!

Virtualmin likes to manage the IP addresses of extra virtual interfaces itself, but you can just tell it that the IP exists in the Shared IP Addresses list in the Addresses and Networking menu.

Dear Joe,

Thanks for your reply!

Could you please tell me how I could set the IP to the Shared IP Addresses list? I have browsed virtualmin and webmin panel but cannot find a place to set this.

PS: in Virutalmin 3.5.7, is "Addresses and Networking" menu replaced with "Network Configuration" menu?

Thanks in advance!

PS: in Virutalmin 3.5.7, is "Addresses and Networking" menu replaced with "Network Configuration" menu?

No. Completely different. You’re looking in the Webmin menus, and I’m talking about Virtualmin specific configuration.

Perhaps the disconnect is that you’re not using the Virtualmin theme? In which case, you would only see Webmin menus with one or more Virtualmin modules hanging out in the Servers category. That’d be the first thing you need to fix…Virtualmin is complicated enough without having to navigate it without the right menus. :wink:

Dear Joe,

I have installed both webmin and virtualmin. And I have found a button called "Networking and Addresses" through Services -> Configure Website. But when getting into this menu, I still cannot find where to set the shared IP.

Please help. Thanks in advance!

o wait, you’re on GPL version.

with the above mentioned theme active go to left pane, select on top virtualmin- open/click "system settings" - click "shared IP Addresses".

Dear all,

Just found the solution for this issue :slight_smile:

Virtualmin panel -> Edit Virtual Server -> Configurable settings, for the "Virtual interface" item, select "Remove now" and click the "Save Virtual Server" button below. Then you need to enter this page again and use "Create now with IP" option to set the new IP (check Already active checkbox if applicable).

The last step is to go to Webmin->Servers->Apache Webserver->Global configuration->Networking and Addresses and make sure “Addresses for name virtual servers” item has been set correctly. It would be something like “”, rather than only “:80”. I think it should be a bug that when Virtualmin remove IP from a virtual host and add a new one, it doesn’t update the file “/etc/apache2/sites-enabled/000-default” correctly. Therefore you need to do your own dirty work :slight_smile:

HTH and Thanks all!

can you check (and set if its not) that you have "Virtualmin Framed Theme" in the webmin module language and themes.

When I log into my site I see in the left pane the Addresses and Networking
It is not under services on my system but on the top level
when clicking on it I see