Cannot access www.website.com but can website.com

Ok, I feel like an idiot because this is probably a really simple solution. I have been working on this project for about 12 hours a day for the last 4 days and I just can’t think straight right now.

I just got Virtualmin up last night currently hosting one virtual website.

If I go to example.com the site comes up no problems
if I go to www.example.com I get Firefox can’t establish a connection to the server at

I manually checked the virtual server file and actually swapped the server name from example.com to www.example.com

Same result

I use a dynamic IP host and added www. specifically even though I have a wildcard.
I checked the Apache2 and example.com error logs with no avail.

If someone can give me a pointer where to look that would be appreciated. I can paste any info needed.

Thanks,
Ryan

Howdy,

It sounds like you may be dealing with a DNS issue of some sort.

Are the nameservers for this domain hosted on your Virtualmin server, or at a third party?

If it’s at a third party, you’d need to configure a DNS entry for ‘www.example.com’.

-Eric

create a CNAME record for www.domain.com.

Adding the CNAME worked.

Although prior to adding the CNAME I could ping both with and without the www and both returned reachable. I am not going to fight it though.

Thanks for the help with the brain fart :slight_smile:

Ryan