Can phpMyAdmin be installed on Virtualmin?

Hello, I think I need to install phpMyAdmin so I can install a CMS on the Virtualmin webserver.
Can I install phpMyAdmin on Virtualmin?
I Created a Database, but that doesn’t seem to allow the CMS to connect the database it runs.


Yes, phpMyAdmin or any other database management tool can be installed a virutal server as desired.

Typically you need to “create database”, then tell your CMS installer (or config file) how to connect to the newly created database including: hostname (often localhost), username, password, and database name.

Ask me about my new support plans which include a FREE copy of Virtualmin Pro!!!

How do I install phpMyAdmin on Virtualmin? I need this to allow a CMS to work.
I don’t see any clear instructions in the Virtualmin forums.


phpMyAdmin is one of the Install Scripts, and is available even on Virtualmin GPL.

You can install that by going into the “Install Scripts” menu for any of your domains.

Note though that we don’t recommend creating databases or adding permissions outside of Virtualmin – you should be able to access a database with the permissions provided after creating it in Virtualmin.

If a database is created outside of Virtualmin, it won’t be backed up.

If you’re unable to access a database created from Virtualmin, then something unusual is going on… that may be the part that needs troubleshooting.


Yes, I’m happy to setup a database within Virtualmin, however the CMS in unable to setup a database.
Therefore, the CMS people said to install phpMyAdmin.

Virtualmin > domain > Install Scripts > Available Scripts > Database > select radio button phpMyAdmin > 4.4.12 (Latest) > Show Install Options > error: This script cannot be installed, as this virtual server does not meet its requirements : phpMyAdmin requires MySQL version 5.5 or later

Virtualmin is currently on mysql Ver 14.14 Distrib 5.1.73, for redhat-linux-gnu (x86_64) using readline 5.1.

I tried SSH into Virtualmin and command # sudo yum update mysql-server, but error:

Loaded plugins: fastestmirror
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base:
 * epel:
 * extras:
 * updates:
No Packages marked for Update

I can’t find any clear Virtualmin documentation on how to upgrade the MySQL?

The packages on your server, and the ones Virtualmin uses, are the ones included with your Linux distribution, which are all stable and known to work well.

You are currently using the most recent MySQL version available to your distribution.

We don’t provide any documentation on upgrading MySQL, as we only recommend using the packages included with your distribution.

The only way to upgrade MySQL would be to use packages from third party repositories; those can often cause problems, and may not be as stable and reliable as the ones provided with your distribution. Problems can also occur during the upgrade process.

If you need a newer MySQL version, our recommendation is to upgrade your distribution, rather than using packages from a third party repository.


I found out that phpMyAdmin is quite flexible and does work on lesser MySQL 5.1 versions, as someone else tested and showed to me.

This tells me Virtualmin is causing a problem of false error.

Moving forward, I manually install phpMyAdmin on CLI, however now:
phpmyadmin is in /home/domain/public_html/phpmyadmin. The browser has, but error: Not Found. The requested URL /phpmyadmin was not found on this server.


As an alternative, you can always give “Adminer” a try, it’s literally one (1) file in size.

Best Regards, Peter Knowles TPN Solutions

Phone: 604-782-9342
Skype: tpnsupport

Ask me about my new support plans which include a FREE copy of Virtualmin Pro!!!

For now, I need to just use what the most common and easiest thing is.
I’ll stick with phpMyAdmin, which should work.
Still figuring out what’s broken.


Just so you know, “adminer” is what we use in place of phpMyAdmin, is a single file in size and equally as powerful. Most phpMyAdmin issues are either related to the version of MySQL or PHP installed on your system. That and/or missing PHP extensions.

I can be contracted for a small flat rate fee to address your installation should you continue to have problems. Drop me a line on Skype if you require my assistance with this or anything else.

Best Regards, Peter Knowles TPN Solutions

Phone: 604-782-9342
Skype: tpnsupport

Ask me about my new support plans which include a FREE copy of Virtualmin Pro!!!

phpmyadmin is in /home/domain/public_html/phpmyadmin. The browser has, but error: Not Found. The requested URL /phpmyadmin was not found on this server.

My best guess is that a global alias has been added to Apache, telling it to look somewhere else when /phpmyadmin is accessed.

That can happen if phpMyAdmin had been installed as a RPM/DEB package.

It’s possible that package was since removed, but the config may be remaining, causing the problem you’re seeing.

You may want to review your Apache config, and look for any lines in it that are setting up a phpMyAdmin alias.


Thank you for the reply.
I don’t think an RPM/DEB package was installed into the Virtualmin server, running Red Hat CentOS 6.6.

phpMyAdmin was
downloaded from
using this file: phpMyAdmin-4.4.12-english.tar.gz,
into directory Virtualmin/home/,
then unzipped and
renamed to phpmyadmin.

There’s an apache config file named httpd in /usr/sbin, however editing the httpd file show only gobbledegook script, unlike the usual script.

I found /etc/httpd/conf/httpd.conf which has a correct httpd.conf file.
/etc/httpd/conf/httpd.conf code seems to show all the virtualservers/virtualhosts set up with the same style code for each virtualhost.
I don’t think there’s any global alias code.

Someone thinks I should install to the main Virtualmin.
I checked /usr/share and there’s only a php direcory, not phpmyadmin directory.

I found this to install phpmyadmin on Virtualmin, but I’m wondering if apache and phpmyadmin are already installed on Virtualmin.

  1. If you want to install PhpMyAdmin from YUM’s repository, you can check this page (, look for “Install Apache, MySQL, phpMyAdmin”
  2. Edit /etc/httpd/conf.d/phpmyadmin.conf
  3. Change internal “Aliases” in phpmyadmin.conf and save it
  4. Restart Apache (/etc/init.d/httpd restart)

According this link, installing Virtualmin should install phpMyAdmin, but phpMyAdmin is not in the /usr/share folder?

So, still can’t install a CMS, so trying to install the phpMyAdmin database.
Can someone clarify the permissions which might be a factor?
I manually installed phpMyAdmin (Virtualmin Install Script has error) on root and also the /home/
I assume I set permissions to 777 in root or /home/

I created the Virtualmin database, but apparently I need to set full privileges for the user.
I’m trying to install phpMyAdmin, but error: No package phpmyadmin.
I then need to figure out how to join the Virtualmin database to the CMS.

I set /home/ to 777, but still doesn’t load? works and loads. refuses to load.


If files in the main public_html folder are accessible, then the only permission that should matter are to make sure that the phpmyadmin folder is world readable. You can do that using “chmod 755” on the phpmyadmin folder.


The /home/ folder’s permissions are: drwxr-xr-x 10.

Ok, so phpMyAdmin fixed and working on Virtualmin.
Now back to the error: phpMyAdmin error: You should upgrade to MySQL 5.5.0 or later.