Can not Access Virtualmin after update

i update virtualmin lasted version

virtualmin aleart me " not enough disk space for backup"

after that i can not access virtualmin

can not /etc/init.d/webmin restart

no output for netstat -an | grep :10000

i see /var/webmin/miniserv.error.

Error: Home directory must be an existing directory for website FTP users Error: User's home directory is relative to the domain, and so must not start with a / Error: User's home directory is relative to the domain, and so must not start with a / Error: User's home directory is relative to the domain, and so must not start with a / Error: User's home directory is relative to the domain, and so must not start with a / Error: User's home directory is relative to the domain, and so must not start with a / Error: Home directory must be an existing directory for website FTP users Error: Missing or invalid home directory [22/Oct/2012:15:52:38 +0700] Reloading configuration

i try command df -h

Filesystem Size Used Avail Use% Mounted on /dev/sda8 996M 980M 0 100% / /dev/sda9 152G 5.1G 140G 4% /home

How to resolve this problem, thank you

*** sory for my english language**
i’m thai ,

Hmm, well, your disk is indeed full… that may be contributing to the problem.

I’d recommend freeing up some space on your / partition, so that whenever you run “df -h”, it no longer shows “/” as being 100% full.

Once you do that, try restarting Webmin again, and see if you’re then able to access it.

-Eric

my “/” is avariable now ,

i use “du --max-depth=1 -h”
and clear this file /etc/webmin/bandwidth/hours

but i can not start webmin now…

Howdy,

What does “df -h” show if you run that now?

Also, what is the output of these two commands:

ps auxw | grep webmin netstat -anlp | grep perl

]# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda8 996M 686M 259M 73% /
/dev/sda9 152G 5.1G 140G 4% /home
/dev/sda6 9.7G 151M 9.1G 2% /tmp
/dev/sda5 9.7G 151M 9.1G 2% /opt
/dev/sda3 20G 2.0G 17G 11% /usr
/dev/sda2 30G 2.5G 26G 9% /var
/dev/sda1 996M 62M 883M 7% /boot


]# ps auxw | grep webmin
root 4099 0.0 1.4 34848 30188 ? Ss 20:40 0:00 /usr/libexec/webmin/virtual-server/lookup-domain-dae
mon.pl
root 12828 0.0 0.0 4028 712 pts/0 S+ 21:01 0:00 grep webmin

netstat -anlp | grep perl
tcp 0 0 0.0.0.0:20000 0.0.0.0:* LISTEN 4152/perl
udp 0 0 0.0.0.0:20000 0.0.0.0:* 4152/perl

Okay, your available disk space looks good.

What output do you receive while restarting Webmin with this command:

/etc/init.d/webmin restart

Also, what distro are you using?

And what does this command show:

free -m

not anything when i use command
]

/etc/init.d/webmin restart

this is output for free -m

free -m

         total       used       free     shared    buffers     cached

Mem: 2017 1143 874 0 175 471
-/+ buffers/cache: 496 1521
Swap: 4094 0 4094

My Distro is
CentOS release 5.8 (Final)
Linux 2.6.18-308.16.1.el5 i686

i try update webmin

this is output

yum update webmin

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • base: mirror1.ku.ac.th
  • extras: mirror1.ku.ac.th
  • updates: mirror1.ku.ac.th
    Reducing CentOS-5 Testing to included packages only
    Finished
    Setting up Update Process
    Resolving Dependencies
    –> Running transaction check
    —> Package webmin.noarch 0:1.600-1 set to be updated
    –> Finished Dependency Resolution

Dependencies Resolved

Updating:
webmin noarch 1.600-1 virtualmin-universal 20 M

Transaction Summary =====
Install 0 Package(s)
Upgrade 1 Package(s)

Total size: 20 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test

Transaction Check Error:
package webmin-1.600-1.noarch is already installed

Error Summary

thanks.

Now , i can start webmin

list of /etc/init.d/

# pwd /etc/init.d #ll -rwxr-xr-x 1 root root 0 Sep 22 01:13 webmin -rwxr-xr-x 1 root root 1559 Apr 11 2012 winbind -rwxr-xr-x 1 root root 1634 Mar 31 2010 wpa_supplicant

i rename “webmin” to “webmin_fail”
and replace this file from anoter server

and access to https://xxxxxxx:10000 by root

webmin show manu "system information " and “Log out” only…

Ah! It sounds like the Webmin init script was corrupted.

That shouldn’t happen though, and if you’re continuing to see problems, it’s possible that other files have been corrupted too :-/

That may be related to having run out of disk space – something may have tried writing to those files, not been able to, and ultimately corrupted the files.

Do you have a “Webmin” option at the top-left?

If so, you could try going into Webmin -> Webmin -> Change Language and Theme, and make sure that the theme is set to “Virtualmin Framed Theme”.

-Eric