But I don't *want* mail!

I work at an ISP that does more than just web hosting (shocking in this day and age, I know) and as a result, our mail server is separate from our web server for various reasons. All of our hosted domains have their e-mail on that other server instead of our webmin site.

One of those resons is so that we can migrate to a shiny new control panel like, oh, say Virtualmin, after years of using “something else”, without causing massive disruption to our clients. The initial install of Virtualmin seemed to have gone fine, I managed to make it so Virtualmin wouldn’t bother creating new mailboxes with new users,and a few sites were set up on the new server. But after upgrading Webmin to the latest version (1.390, and we’re also using the GPL version of Virtualmin), things suddenly didn’t work so well, and now I can’t create new virtual hosts without Webmin attempting to create new e-mail boxes and set up disk quotas for partitions it ought not to. I now get this error message:

Creating home directory …
… done

Creating administration group foobar …
… done

Creating administration user foobar …
… done
Creating mailbox and aliases for administration user …
Failed to create virtual server : setquota: Not all specified mountpoints are using quota.

Part of the problem seems to be an inherent flaw in Virtualmin’s design… that is, you can’t just turn off e-mail. It’s tightly integrated into everything that it does. And while I would like to request this feature in the next version, what I really need right now is a workaround to either make Virtualmin stop trying to create administrator e-mail accounts, or to fix the quotas so that they include the e-mail accounts. I haven’t been able to figure that one out on my own yet. :confused:

Just go to features and plugins in the VM system settings and uncheck mail.

Hmm. That’s interesting. It looks like I’ve found a bug, because I can’t remove the checkmark for “set as default” for either BIND or mail. I can remove it, and save it, but when I refresh the page after saving it, the checkmark is still there.

It also continues to try to create mailboxes for new domains.

After digging a bit, I also see in /etc/webmin/virtual-server/config this line:

disable=unix,mail,web,dns,mysql,postgres,ftp

Which, ah, I expect means that mail isn’t supposed to be enabled by default.

I found the problem. Virtualmin quotas don’t work for some reason. I’m taking this to another thread.