Bug in forum!


I have just posted with the subject "Install Scripts" the only trouble is text in the post is not what I have just posted :frowning:

I think that a problem occurs if the same subject is used

As the text that appears in my last post is signed by a user called Shanon last year, I think that the subject name was the same as my last post and something has gone wrong somewhere and an old post with the same subject as mine is showing.

So I am gong to post my question here…

Its to do with the preinstalled install scripts in VM Pro (EC2 version)

I am trying to install phpnuke 8.0 and get the msg saying

This script cannot be installed, as it requires PHP version 4.

On the phpnuke site it says one of the prerequisites is

PHP version 4.1.x or better (mod_php) Apache module.

I thought that VM pro was using php5, or am I incorrect?

Thanks in advance for any help

Will<br><br>Post edited by: willrendell, at: 2008/08/13 11:07

Hi Will,

Well, your post looked okay to me – I wonder if the problem you’re seeing is because you were the author of the post. Anyhow, Joe can look into that part :wink:

I did respond to your post, hopefully you’re able to view it here:


Thanks for the link I am going to take a look now.

I still cant see my text when I click on my "install scripts" post, this is what I see with out any replies.

As I move around Virtualmin more, I am getting much more comfortable with it. I am finding lots of treasures. Hopefully my questions will stop soon.

This question is about install scripts. Some of my clients use an open source program called Plogger for their photo galleries. I am wanting to move these last few users from my old server, which doesn’t use Virtualmin, to my new one that does. I would like to be able to install Plogger automatically, then move the data from their dbs to the new server. I followed the instructions on how to make an install script. I used the wordpress.pl file, copied it to plogger.pl and changed all the instances of wordpress to plogger etc.

I tried to add it to the list of available scripts, and it says that it was added successfully. I go to the disable scripts page and find that there is a blank line at the bottom, with a check mark to the left. There is no name. So I try to enable it. As soon as I hit save, the page reloads, and the script is still disabled. I have no idea if my script works, because I cannot see it to test it.

What am I doing wrong?

Any help with this would be greatly appreciated.