BUG: HTTPS2 not work per single virtualserver && SSL crash whole http (port 80)

Operating system: Ubuntu
OS version: 20.04

If I do setup different virtualserver (with nginx), it doesn’t matter at all, which setting is made on the VirtualHost setting:

DevTools (in the Network-Tab) show that http2 is used anyway.
I’ve found this stackoverflow-thread. So it seems, if at least one server has http2 enabled, it is enabled for all.
So it might be better to don’t display an “HTTP2 mode” Select-Box here for each Port in the HostSettings, but put this only into the global nginx-setting. The current solution is very confusing!

In fact, the things will getting much more strange now.

If I change the setting for “SSLMode” to YES for an Port 80 Domain (not important which one), it breaks the whole Webserver (for each user) at Port 80, without any error-message. HTTPS-Pages still work like expected.

If SSL at Port 80 is a problem, then the select-field should be disabled in the VirtualMin⇒Nginx GUI.