Broken Installation - unmet or locked dependencies

OS type and version Kubuntu 22.04.2 LTS
Virtualmin version 2.021

Ladies and Gentlemen:
I have recently had to rebuild a Linux Kubuntu machine to version 22.04.2 LTS due to an issue with the display driver compatibility in 23.04. This unfortunately required a pretty much “wipe it and start over” rebuild. The Platform is a Xeon 24 core machine with 24G of memory installed (an old rebuilt server…)

I went through the installation procedure for Webmin 2.021 and had one issue: during the “sudo apt install webmin” instruction there was a dependency that proved difficult to resolve (perlapi-5.28.0) – I ended up resolving it by using the “sudo aptitude install webmin” command and using the SECOND option, which apparently did some package tradeoffs…

At this point webmin started properly.

Now to the issue: On the system dashboard there is an indicator that 4 Package Updates are available. When I attempt to do the package updates I get the following response:
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Reading package lists…
Building dependency tree…
Reading state information…
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libauthen-pam-perl : Depends: perlapi-5.28.0
libfile-fcntllock-perl : Depends: perlapi-5.28.0
libgnustep-base1.26 : Depends: gnustep-base-common (= 1.26.0-4+deb10u1) but 1.28.0-4build1 is to be installed
Recommends: gnustep-base-runtime (= 1.26.0-4+deb10u1) but 1.28.0-4build1 is to be installed
shim-signed : Depends: grub-efi-amd64-signed (>= 1.187.2~) but it is not going to be installed or
grub-efi-arm64-signed (>= 1.187.2~) but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Could I get some hints as to how to correct the situation?
Best Regards…
Tony Radice

To be clear. You are using Virtualmin? It didn’t automatically install Webmin for you?

Try apt clean; apt update.

And, then apt-get -f install

If that doesn’t fix it, the problem is upstream and there’s probably no reasonable solution.

These are not our packages. These are packages provided by your OS.

Assuming you have already tried apt clean; apt update, then the repos you’re using are broken, in some way. We can’t fix it. And, you probably can’t fix it, except by using an OS or repos with working Perl packages.

This has nothing to do with Webmin. Same problem as above (you’re trying to use one or more apt repos that are messed up, either locally or upstream), but it is not related to Webmin in any way.

The solution is to use other repos or a different OS that does not have broken repos, if there are no working repos for the OS you’re using. (I’m unfamiliar with Kubuntu, except to know it is a version of Ubuntu with KDE as the default desktop environment).

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.