broke webmin- cannot restart after modifying faile

i was going though setting trying to sort out a prroftp issue, and i decided to change the max failed attempts to 3, and to add 6 failed attempts as a lock. then hit the restart button.
after appx. 30-45 seconds- hit the refresh button on firefox. nothing. i was also SShed into machine- so i ran top- nothing strange- but vi running at 99%- let it go for well over a minute- still no change- either in top, or with trying to access via firefox.
closed the browser- re-started firefox. no change. top still showed vi runnig at 99%- so i killed it. i figured after 2-3 minutes something was not right.
now- i cannot get into webmin. tried stopping with /etc/webmin/stop then starting again. stop told me PID was no longer running(did not clip exact wording) and start did not report any issues.
still do not see miniserv.pl in top- or able to access via port 10000

so? ? any ideas what i hosed? ad- what to repair? hoping i can remove a config- or edit via shell…

thanks all.

I’m just guessing but, it sounds like the OOM killer on your system has kicked in and is killing stuff at random. This happens if you have a runaway process eating HUGE amounts of memory (leading to swap thrashing and overall slowness, while also ending up with killed processes).

Sometimes you can find the process and kill it in time to avoid a reboot…sometimes not. The command to kill a particularly troublesome process is "kill -9 PID", obviously replacing PID with the actual PID of the runaway process.

Obviously, this isn’t normal.

It could also just be that your system doesn’t have enough memory for all of the things you’ve got running on it. See the “Virtualmin on Low Memory Systems” guide, if you have less than…maybe 256MB.

joe- this was unusuall behavior for the system, and i was hoping i had hit something in the module that i was working in.
system- DL380 - single P3-1.4G 1Gig RAM, 2x 18G fast scsi. about 80 domains, most doing next-to-nothing, a few with usage, 3 active. top shows load average of anywhere from .2 to 2-3 depending on clamav firing. (one of my other questions today) i tried to stop webmin and then start it- no luck. doing /etc/init.d/webmin start/stop - first time they complaied about a PID not existing. afterward- was nothing. not sure if i am covering what you need to offer direction…

good morning all- a solution has been found. beer!
actually- that was only part of it. this morning- began goig though my notes- trying to sort out what i did. went back into top- and began sorting by user- found two more instances of vi running. and another copy of miniserv.pl. killed all- had to use kill 9 to make them die. then- restarted webmin- everything seems fine now.
so- Q?? does webmin use vi to write to and configs? or- was it something else that got hung up- and just stopped ‘things’ from working right??
no clue- but a few more things learned.
thanks all for looking- and joe- thank you for helping.

sort of- the solution. stopped last night when i realized i was banging head against wall…
i had been using vi for some minor edits. not sure if i caused THAT issue- but it seemed to do something with /against miniserv.pl. after killing the 2 instances of vi that i found. i was able to stop miniserv and restart it- and THEN was able to log into webmin via web.
still having problems with proftp. i stopped it- then removed it using webmin- then installed it via webmin. same issues. i CAN connect- just not view- change- access anything.

and!- read on board somewhere you are in PA?
thanks again-
keith

Aha, I have an idea.

So you can log in – but no files and such display, it just seems to timeout whenever trying to do anything?

You might have luck with the FTP connection tracking kernel module, which can assist in cases like yours.

Try logging into your server over SSH as root, and run this:

modprobe ip_conntrack_ftp

Then try FTP again – does that help?

And indeed, I’m from central PA – are you in PA as well?
-Eric

ERIC~!~!~!~!
thank you- that allows me to log in from command line WOOOOOOOOO~!~!~!

now- i just need to get a GUI type thing for the client to work.

what exactally did i do?? will google it in a moment.
thank you!
thank you~!~!~!

and- thank you~!~!

yep- we are. east of you- where 81 crosses 80- then a little south.

thanks again.

wow.

found this whilst searching google for the above-
quote-

I don’t know about the command, however, look at your file:
/etc/sysconfig/iptables-config
the first non-comment line in my CentOS5 system is:
IPTABLES_MODULES=“ip_conntrack_netbios_ns ip_conntrack_ftp ip_conntrack_tftp”
end quote-
my iptables-config shows this=>

Load additional iptables modules (nat helpers)

Default: -none-

Space separated list of nat helpers (e.g. ‘ip_nat_ftp ip_nat_irc’), which

are loaded after the firewall rules are applied. Options for the helpers are

stored in /etc/modprobe.conf.

IPTABLES_MODULES="ip_conntrack_netbios_ns"

can i assume to add the ip_conntrack_ftp into that line?
if so- then hoping it is solved!
thanks again.
keith

Hey Keith,

Just to be clear, the file you’re looking at is a RHEL/CentOS supplied file, not a Virtualmin one. It’s part of the base distribution.

Anyhow, yeah, I believe if you add ip_conntrack_ftp to that line, you should be in good shape! You don’t need the tftp related module unless you know that for sure that you’re using TFTP (it’s fairly rare these days, and it’s a separate daemon that you’d have installed).

Have a good one!
-Eric

thanks again!
i need to send you beer- or cookies. your choice.

and- found this while researching- installed it- seems to work.

http://help.unc.edu/4681

nice little program- reminds me of CuteFTP…

hoping the client will like it- as FileZilla and SmartFTP both are still having problems. but! my end is done.
thank you again.
(is there any way to private message here?)
let me know about the beer/cookies.
keith

Is beer the solution, the problem, or both? :slight_smile: A good Simpson’s quote:

"Here’s to alcohol, the cause ofâ