Bookworm release does not have a release file

OS type and version DEBIAN 12.2 REQUIRED
Webmin version REQUIRED
Virtualmin version REQUIRED
Related packages Virtualmin SUGGESTED

Bookworm fails to install… Hangs up with error 100

Bookworm release does not have a release file.

doh post deleted by author ahhh well everyone seems to be tight on using rocky around here its seems. Hrmmm I might just have to see what all the fuss is about.

It was wondering what Bookworm was then it came to me when I did google search.
Not sure what Rocky has got to with anything. Plenty users using Debian. Maybe they are asleep or working.
The forum has chat on Debian 12, use search.

I did several searches I guess my terminology wasn’t correct.
But thank you bookworm not bookmark …

Fixed opps, maybe they can use that on next release :slight_smile: Hopefully virtualmin download server is not down. Try again and see if it still errors.

Yeah IDK tried it 7 ways from sunday actually same error each time so beats me maybe something simple says no release file. Maybe cause its 12.2 and not 12.0 and it simply needs to have a wildcard for checking like 12.x? I’m not entirely sure how this all works with their script never even looked at it I just know it worked well with buster so I subscribed and paid and donated good project love it just gotta get over this next hump. Another good open source project is harvester pretty impressed so far with its HCI I’ll have to get a bit more into it but either way I enjoy it thus far.

I was looking at Xen Orchestra but hot damn 1k per year for a license I’m just a little guy hosting a fricking small server similar to but smaller than some folks home labs sheesh of course its a production environment on the web end so I need something with security updates.

I remember the script can be edited that way. See if I can find it. But I thought it would error with not supported OS.

Can’t see anything that will help at these lines, look like no support for under 10

We need to see the exact error, but I can also tell you that any repo with “bookworm” in the name is not one of ours, so whatever problem you have is not with our repos or our install script, but probably with the distro repos or some other repos you have enabled.

But, with the actual error we may be able to guide you on fixing it (probably network or upstream repo problems).

No. All minor versions of a release are supported.

hrmmm I guess I just followed on the debian website to get the ISO but possibly I clicked the wrong link and downloaded the wrong ISO DOH!

Disable the cdrom repos. You don’t need them.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.