Bind zone reset

SYSTEM INFORMATION
OS type and version Ubuntu Linux 18.04.6
Webmin version 2.001
Virtualmin version 7.3-1 Pro

I want to install the analytics plugin but I get the error:

Failed to save enabled features : Errors were found in your system’s BIND configuration : zone sgc233.poseidon.salford.ac.uk/IN: has no NS records, zone sgc233.poseidon.salford.ac.uk/IN: not loaded due to errors., _default/sgc233.poseidon.salford.ac.uk/IN: bad zone

Is there a way to quickly and easily restore a user/zone’s bind settings to the defaults, those used when creating a new user/domain?

Hello,

Yes, there is an excellent feature in Virtualmin that enables you to quickly reset any feature for a virtual-server (domain). Have a look at Limits and Validation ⇾ Validate Virtual Servers page and Reset Features tab. Choose the virtual server which features you want to be reset, then choose DNS domain and set Fully reset by turning features on and off option to Yes, and hit Reset Now button to perform feature reset.

1 Like

Wow! It’s like the first time I have notice this feature even though I have been using Virtualmin for ages.

This is such a wonderful thing to have.

Hi Ilia

That’d be great if it worked but I get the error:

Failed to reset features : No valid features to reset selected

I selected the virtual server, selected DNS domain, turned “Fully reset by turning features on and off?” to Yes and I’ve tried with and without “Continue even if settings would be lost?” enabled but I always get the same error when I click “Reset Now”.

This error indicates that DNS feature is either not enabled or not associated with the given virtual server. The work-around would be (if you sure that DNS was enabled for the virtual server), is to at first associate DNS feature with virtual server using Disable and Delete ⇾ Disassociate Features: Associate and Dis-Associate Features page.

1 Like

Thanks Ilia! That fixed it!