BIND Setup quesiton

I did a report on my domain at and it warned me that my nameservers would do recursive queries. So i went into Bind and under Miscellaneous Options set "Do full recursive lookups for clients?" to NO.

This fixed the problem on the DNS report, but it also stopped any local DNS queries being done recursively, by postfix for example

How do i prevent external clients from using my server for recursive queries but still allow local requests to be resolved correctly


Looks like adding Address and Topology - "Allow recursive queries from" sorts it out

That didnt actually work, although it looks like it should have. I was just getting a previously cached lookup. I made sure to restart bind.<br><br>Post edited by: ChrisBlackwell, at: 2008/01/25 04:16

have you found a solution?

Im looking into it as well since I have the same issue since recently.
before it was fine but Im not sure what changed it.
It did change after an update

Looks like adding Address and Topology - "Allow recursive queries from" sorts it out

This should work. What’s the entirety of your /etc/named.conf?

according to Jamie

So it sounds like what you want is to allow recursive lookups from your own system and network only.

Do this is, go to Webmin -> Servers -> BIND DNS Server -> Addresses and Topology, and in the ‘Allow recursive queries from’ field enter , your systems IP, and the IPs of any other boxes on your local networks. Click Save, then go to the Miscellaneous Options page and change ‘Do full recursive lookups for clients?’ to ‘Yes’, and Save again. Finally, click ‘Apply Changes’.

This seems to work so far. Only doesn’t seem to be enough

(edit won’t work)

also I wouldn’t use but instead use as it shows more