BIND and newly created Sub-domains


[Virtualmin GPL 3.83 on Centos 5.5]

In the past, I used to create several subdomains - without having issues and the virtual servers validation always exited without any error.

Recently I created a new subdomain - as usual - but running the validator I get the following error message for that subdomain:

BIND DNS domain : The following errors were found in the DNS records : usage: named-checkzone [-djqvD] [-c class] [-o output] [-t directory] [-w directory] [-k (ignore|warn|fail)] [-n (ignore|warn|fail)] zonename filename

The subdomain is running smoothly, though…

I’ve tried creating some other subdomains on other virtual servers and the result is the same for all of them.

Virtualmin recently updated to the newest version… maybe an error in the validation script?

Thank you for any support


My suggestion would be to turn on Webmin’s Debug Logging so you can see what command exactly it tried to run, then compare it to the syntax that named-checkzone is expecting.

Maybe a recent update of BIND changed the command syntax?

So, anybody have had such an issue or please have any clue?

Sub-domain creation and validation used to have no problems, until now.

In the present, validation reports the same issue with ‘any’ sub-domain newly created…

Am I the only one experimenting this?

Yeah, I haven’t seen anyone else running into that before (and I checked on a few CentOS systems just to be sure).

But as you’re seeing, it looks like it’s trying to call named-checkzone without a parameter in one case.

If you look in the drop-down list of Virtual Servers on the top-left of Virtualmin, do you see any unusual entries in there? Perhaps even a blank entry?


hey, thank you, Eric.

Yes, it seems that parameters are not passed to the script in that case and in “ANY” involved newly created subdomain (I tried creating others, too, and having the same issue).

Among the domains in the drop down menu, I have a disabled domain and nothing is looking strange to me…

Unfortunately, I don’t have older subdomains anymore (I had several, in the past) in order to make a comparison. But I know that - before every backup I want to run - I launch verification and this is the first time in 5 years, now, that I happily use Virtualmin, that this happens…


Hmm, I think I have to ask some possibly stupid questions here, since I have no immediate idea what might be wrong. :slight_smile: (I just created a subdomain on my 3.83 test system on Ubuntu 10, and there’s no such issue occuring there.)

Are the subdomains that fail the test are otherwise working okay? Is the BIND zone correct (check in Webmin’s BIND module)? Does it have the BIND DNS feature enabled at all? With “subdomain”, do you mean actual Virtualmin sub-servers?

Yes, the sub-domain (sub-server) failing is working great… (!)

I went in Servers>BIND>Check Bind cfg and reported OK;

Then, in the zone where the sub-server is failing I did Check Records and it reported OK;

And this is the created by BIND… If there is something wrong with it, I don’t see it:

$ttl 38400
@ IN SOA (
38400 )
@ IN NS IN A IN A IN A IN A IN A IN A IN A IN A IN MX 5 IN TXT “v=spf1 a mx ip4: ?all” IN A IN A IN A IN A IN A IN A IN A

And, this is how the validation report looks:

Beginning validation of selected virtual servers. Any problems found will be shown in red …
BIND DNS domain : The following errors were found in the DNS records : usage: named-checkzone [-djqvD] [-c class] [-o output] [-t directory] [-w directory] [-k (ignore|warn|fail)] [-n (ignore|warn|fail)] zonename filename
All features OK

Alright, this rather looks like a Virtualmin problem to me at the moment. Possibly some internal data files got set up incorrectly, so that the check function passes wrong parameters (here: no zone name and just /etc/ for the zone file) to the check command.

Digging further into this would fall into the coders’ domain, since it requires knowledge of which script gets called for the domain validation, which part of that is responsible for the BIND validation, and which data files it fetches the necessary values from. That is unfortunately beyond my scope of Virtualmin knowledge. :slight_smile:

I could try to figure it out by checking the source code, but it’d be way easier if someone with profound knowledge of said code (namely Joe or Jamie) did that. So, Eric might want to pass this along to the team. If he doesn’t notice these posts, you might also open up a bug report issue, if you’re certain that on your end all is correct, which the coders will definitely see.

Thank you, Locutus.

Yes, It appears that it is something script related - but I can’t swear on it…, though.

From the log, for the failing part:

6574 [02/Feb/2011 18:30:12] root bind8 CMD “cmd=named-checkzone /etc/ 2>&1 </dev/null”

While, for any other virtual server is:

6574 [02/Feb/2011 18:30:12] root bind8 CMD “cmd=named-checkzone /var/named/ 2>&1 </dev/null”

I have to underline that the named-checkzone command passed to the command shell with the right parameters for the domain containing the subdomain in question, returns a wonderful “OK”.

Thank you everybody for any fix to this…


Thank you, Locutus. Your interest is very much appreciated.

I send in a report to Jamie regarding all that. It does seem like a bug of some sort.

So, he’ll look into that, and hopefully have it fixed up soon :slight_smile:


Thank you Eric, I am happy to have contributed in some way… :wink: