Bandwidth log file keeps growing

I have turned on the bandwidth monitoring. It obviously marks every packet sent or received and uses firewall rules for that. But that functionality didn’t make any log-rotation to that bandwidth log file and now it keeps on growing even though this isn’t even on production yet.

So how does that function work and can I make my own log-rotation for it?

Post edited by: matti, at: 2007/07/05 08:48<br><br>Post edited by: matti, at: 2007/07/05 08:49

Hey Matti,

Sounds like a bug. You shouldn’t have to manually do anything. I’ll ask Jamie to stop by this thread.

Hi Matti,

Log rotation should be done by the /etc/webmin/bandwidth/ cron job, which also parses the firewall log into files that Webmin can generate reports on.

That said, for a hosting server that gets a lot of traffic, I recommend against using the Bandwidth Monitoring webmin module, as it logs every single packet. What you probably want it monitoring of bandwidth use on a per-domain basis, which can be setup in Virtualmin by clicking on Bandwidth Monitoring under System Settings on the left menu.


thanks for the info. Somehow I thought these were the same bandwidth monitoring. I already had this per-domain basis bandwidth monitoring on. I only checked log rotations and not cron jobs when trying to find the log rotation. Maybe the large size of the log file was due to the massive logging and rotations were still working.

Any reason by the way why bandwidth isn’t on the front page as quotas is displayed?

Yeah, I would recommend turning off monitoring in the Bandwidth Monitoring module, as using on Virtualmin’s per-domain stats.

As for bandwidth graphs on the main page, I do have an item on my TODO list to implement this…