BAD Updates causing breakage

OS type and version CentOS Stream Linux 8
Webmin version 2.021
Virtualmin version 7.7 pro
Related packages SUGGESTED

Ok there’s sometimes issue after updating but this last one is horrendous, i’ve came across 2 significant issue already I wish I hadn’t updated & i’m considering using another product now as I upgraded all the servers to pro so as not to experience problems yet I am as below since last update.

  1. The main user cannot be edited or changed now as it wont save reporting" DOMAIN is not managed by Virtualmin" the format is usually but this has changed to “firstpartofdomain” only!
  2. now when I go to restore from back up is says " (Server does not exist, will be re-created) " but the domain/server does exist, I haven’t gone beyond this or tried to restore as don’t need the breakages…

Support would be much appreciated as these errors are preventing management & making me want to bail.

Thanks Nick

I can’t help, but I am curious, what would you prefer to use instead?

Submit a support ticket seeing you use pro version.

1 Like

I haven’t even thought that far but equally I pay monthly for a professional product, countless times I have had issue with updates and I end up literally loosing hours even days at it and its extremely stressful to have so much built that keeps becoming broke it makes me worry to update I pray every time! Id expect the test version to be the GPL version hence why I use the professional as im doing it for business not for recreation so it needs to be stable else its downtime will & does loose customers, im not knocking the product ive used cpanal I much prefer Webmin/Virtualmin its a class framework I just find myself solving issues far to often both time consuming & troubling, there does that satisfy your curiosity?

Grade B Supported Systems
The following operating systems are not recommended for new or intermediate users. You will need to have experience with your OS and with Virtualmin to successfully use any of these operating systems. Don’t bother asking for help installing on any of these systems in the forum, you should only be attempting it if you already know what you’re doing. Otherwise choose a grade A supported OS.

CentOS Stream 8 and 9 on x86_64 (using --unstable param) is in their list of Grade B Supported systems. Maybe it would be worth the trouble in the long run to build up and move to a Grade A Supported system.

Yeah interesting however when Iinstalled this system I was using a recommended version the recommendations have since changed seemingly since Centos split… Nevertheless the problem came after the last update everything was fine until then.

We haven’t updated Virtualmin since April, so I don’t think it’s caused by an update (Webmin and Usermin were just updated, but I can’t think of any way they’d cause the behavior you’re seeing as they aren’t really directly involved in Virtualmin domains).

I’m having a hard time coming up with an explanation for this behavior, though. What else besides the Webmin/Usermin updates happened on the system? Did you restore a Virtualmin backup? It’s possible to backup the Virtualmin configuration, which when restored can change the domain username format, etc. But, even if that happened, it shouldn’t break existing domains.

As long as your sites are currently functional, I think that’s a very good idea (not trying to restore any backups or anything, I mean). If Virtualmin is confused about its domains, it seems very risky to try restoring existing domains (or any domains, really, given the circumstances).

I’ll look over the latest Webmin release changes to see if maybe there’s something that could explain this; I think it’s a red herring, but I also don’t have other good explanations. I’ve never seen this behavior, and I don’t think anything exactly like this has ever been reported. (Which makes me think it must be new code. But, nobody else has reported it since the Webmin update, either, so if it is new code it’s rarely hit.)

And, yes CentOS Stream is not supported, but we’ll do our best. It probably hasn’t diverged in dangerous ways, but we also can’t be very confident about it. I would have recommended you switch to Rocky or Alma using the conversion tools that provide, rather than going to Stream.

The latest Webmin & Virtualmin update as of yesterday has solve all problems on both servers great work guys!

lol. I thought when the thread started that it was believed to be caused by those updates. But, I’m glad it’s sorted. :man_shrugging:

Im pretty sure it was my friend but equally it has been resolve/sorted/addressed/solved/repaired by the last virtualmin/webmin update to which im over the moon, I will now migrate to Alma or Rocky I was unware my centos version was no longer supported as it was at the time of installation then some weird split happened with centos I was just horrified as was once a stable OS then some major disagreement then a split that followed then it becomes unsupported, let me tell you Joe in my universe that just wouldn’t happen, it almost certainty wouldn’t be allowed but alias this is not my universe evidential it is Satans for pulling that crap. Anyway I am over the moon I love it when my Virtualmin installations are working as they should its a beautiful hosting framework I loved it from first sight but equally like a misbelieving beautiful woman if they go bad you know they can hurt you like nothing else, ive had server situations where my whole world flashed before my eyes and im wondering if there’s any point in going on. That not healthy so im on it, by the way Joe im going through a spiritual awakening and sense comes to me like its a fret train and im walking the tracks, im thinking what you guys want to do if you want to stand above the rest like the king ding alings, you need to develop webmin to have the ability to be remotely checked & repaired, to develop a A.I. type assistant that someone like myself can go to online, I provide it SFTP / SSH root login and the script checks all the files and then isolates the problem by comparison to original files & scripts that check the structure of files using algorithms etc, many different options there, but to provide an insight which a user can then address the pro version of course, it could also offer for a fee a remote repair where it aimed to restore a working system as thats what 99% are wanting so they could either do it themselves or press of a button & a fee your A.I. support assistant could do it taking a backup before making change… working 24/7 for you and as many instances as required… KERCHING… Joe… Kerching, it would take some development I know enough about scripting to know that and it would be on going but a large percentage of uses have not the experience to deal with issues and posting to forums and waiting for support or helpful advice is frustrating in itself. Thanks again for resolving my server issues whether by chance or if someone spotted & corrected the error doesnt matter it is awesome to have it resolved.

If OpenAI can’t make an AI that doesn’t give dangerous advice, despite their $10 billion in funding from Microsoft, I’m confident we can’t make anything better with effectively zero funding and almost all volunteer labor.

We’re doing the best we can to make the system resilient and easy to validate (we have Validate Virtual Servers feature, already, which does all that, as best we can, with hand-written code…no AI involved, only our best effort to check for common problems).

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.