Backup Virtual Servers stopped working with most recent Webmin update

All of a sudden, after the most recent Webmin update, my “backup virtual servers” has quit working. It’s always worked fantastically! and this is probably justa minor glitch, but I can’t seem to figure out what it is. When I try to backup all virtual servers to a local single file, I get this:

(bunch of successful stuff removed here)

… Dumping MySQL database s1nget_L0qbmnS5HFz …
… dump failed!

mysqldump: Got error: 1045: Access denied for user ‘root’@‘localhost’ (using password: YES) when trying to connect

Backup failed! See the progress output above for the reason why.


Fine for me on one test server system here. Updated today. Ubuntu

Check user and permissions for db.


Yeah it sounds like the password Virtualmin is trying to use to access the root user for your database isn’t working.

First, I’d suggest running “mysql -p” on the command line, and just verify that the password works properly when you access it manually.

If so, then go into Webmin -> Servers -> MySQL -> Module Config, and there, set the “Administration password” to your current MySQL root password.


Good call on checking first if the password is working manually… Apparently it is not because when running “mysql -p” from command shell, I get:

mysql -p
Enter password: ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)

So it looks like it is NOT using my password in this case. I checked to see that root does in fact have a password set, and it is set to what it has always been so it’s still there. What do you think now?

Ah, you wouldn’t actually want to run that from the command shell, you would need to log in over SSH in order to run that.

The command shell is a good way to run non-interactive commands, but with “mysql -p”, it asks for input, which is something the command shell isn’t able to do.


Thanks os much for your help!!

I logged in locally instead of SSH, then used mysql -p to set the password to the same as it was before. Then went to Webmin -> Servers -> MySQL -> Module Config, and set the Administration password to also be the same… Still didn’t work. What to try next?

I’m still looking for a solution… Anyone have any idea? Worked fine before the upgrade.

Does it detect any problems if you go into System Settings -> Re-Check Config?


No, says it’s all good, finishes with:
“… your system is ready for use by Virtualmin.”

Okay, two more questions.

One, can you create a new Virtual Server without it erroring out?

That will show whether there’s a general MySQL issue going on or not.

And then two, from the command line using SSH again, perhaps try this –

First, run “mysql -u root -p” again, and access the MySQL shell.

Second, run the command “use s1nget_L0qbmnS5HFz” in the MySQL shell as the root user.

Does it change to use that database? Or do you receive an error when running that command?


Yes, it changed to use that database without any errors…

What do you think?

Any help? I am feeling scared, not being able to backup since the update.