Backup to SSH server fails

Hey there! I’m trying to create a scheduled backup where the destination is a remote SSH server.

So far the backups are created successfully, and the directory where they should be copied is also created on the remote server.

When the backups should be transferred to the remote server, however, it shows an error that the backups have vanished from /.tmp/webmin before they could be copied. I watched the directory and can see that the backups are all created, but just before they are copied to the remote server they seem to vanish from the directory. I have also checked the Advanced Options section of Webmin Configuration and as far as I can tell nothing is causing these temporary files to be deleted prematurely.

What should I do?


Backup destination /Backup/26-10-2016 on SSH server
Executed via Virtualmin UI Run by web user root
Started at 26/Oct/2016 15:55 Completed at 26/Oct/2016 16:02
Final backup size 2.73 GB Run time 07 minutes, 03 seconds
Backup type Full Compression format tar.gz
Filename format One file per server (old format) Final status Failed
From scheduled backup /Backup/%d-%m-%Y on SSH server
Encrypted backup? No

LOG (last server and the error message)

Creating backup for virtual server
Copying virtual server configuration …
… done
Backing up Cron jobs …
… done

Creating TAR file of home directory …
… done

Copying records in DNS domain …
… done

Saving mail aliases …
… done

Saving mail and FTP users …
… done

Backing up mail and FTP user Cron jobs …
… none to backup

Copying Apache virtual host configuration …
… done

Copying Apache log files …
… done

Copying Webalizer configuration files …
… done

Copying Logrotate configuration …
… done

Dumping MySQL database billing_db …
… done

Backing up Webmin ACL files …
… done

… completed in 3 seconds
Creating final backup archives in directory …
… done

Uploading archive to SSH server
… upload failed! Password: /tmp/.webmin/9902-26-10-2016 :: No such file or directory

I was getting that exact error also. Its permission error on virtualmin settings. Users can not backup virtualmin settings.
I had set up backups for users. All worked fine individually. I also then set up an admin’s backup of everything. it worked fine. I then tried including “virtualmin settings” in the user’s backups so each could be restored individually. Thats when the error showed up. It seems the user can NOT back up virtualmin settings. Only a root/admin user can. Once I removed the virtualmin settings check boxes from user back ups, all completed normally.

So, in your scheduled backups, features and settings, “virtualmin settings to also back up”… uncheck all those boxes. Only an admin can back those up.

Thanks for your suggestion.

I’m still having the same problem though after deselecting the Virtualadmin Configuration option. It turns out I’m creating the backups using the root account anyway–so it should work anyway right?


How about when you click “back up logs”. Then In the “made by” column…
Does it show run by ‘root/root user’ or by the virtual server owner? You say it root, but thats a check to see who its actually being run by.

My scheduled jobs show root and manually run jobs shows scotw which is a sudo user.

Other user jobs show run by the user.