Backup restore problem as of 6.15

Operating system: Debian 10
OS version:

Maybe some of you have knowledge about the big OVH datacenter fire a few days ago in Strasbourg … I was impacted (6 servers) and so I started very early a lengthy process of migrating about 60 sites (Wordpress, Drupal, Joola, Spip …). I already did about 50 of them no problem at all, thanks to Virtualmin backup/restore functionnality (I had backup in other places :slight_smile:
A few hours ago the 6.15 update showed up and I did it, and all of a sudden I cannot restore anymore … process stops towards the end with the following error:

Restore failed : flush_file_lines called on non-loaded file /etc/apache2/sites-available/********.fr.conf …

If somebody has an idea, the remaining 10 websites I have to restore would be very grateful :slight_smile:


I’m getting the same error on my experimental (local) installation of Virtualmin on AlmaLinux 8.3 RC. I’m sorry for your troubles, but thank you for pointing this out as it’s one less thing I have to troubleshoot.


I found a way around: locally untaring the VirtualMin backup archive and uploading manually files and database … tedious but it’s a solution for my emergency.

1 Like

If you apply this patch and restart Webmin with /etc/webmin/restart command, will it help?

A new release with this patch will be out in a bit, maybe a couple of hours at the most.


Yes thank you very much, was able to migrate 7 more sites, patch seems to be the solution !

Hi @Joe I still have issue with latest install of virtualmin.
Is the patch out ?

Sorry for the noob question but how can I apply this patch ?

Many thanks.

Probably the easiest way if you’re not comfortable in the shell would be in the Virtualmin file manager.

Navigate to /usr/libexec/webmin/virtual-server/ and edit it, replacing the line with the pink (some would say red) background in the linked page, with the line with a green background. Then save the file and restart Webmin.

It will be around line 1710, but not necessarily exactly line 1710.

Make sure that the line is copied exactly as appears on the linked page. Any errors at all, even things that seem unimportant to mere mortals, can cause a Perl script to crash with gusto. You probably should back up the unpatched version of the file just in case.


thanks for your reply.
I am pretty comfortable with shell but the file is not there in debian 10
I also tried to find it in /etc/webmin/virtual-server and it’s not there …

On my debian 10: /usr/share/webmin/virtual-server/


Many thanks @Pierrot seems like we’re in the same boat with OVH crash :slight_smile:

Good luck :slight_smile:

Well I guess there are many people impacted, Netcraft is mentionning 3,2 millions websites … I feel myself lucky, thanks to Virtualmin backup-restore functionality I was able to rebuild 60 sites in 3 days with almost nothing lost (had a daily backup), I’m now waiting for SBG3 to restart, I still have 3 big Nextcloud servers down … I do have backups but 600gb installations are a lengthy process to restore (plus process of ordering and starting new servers) so I’m hoping for a quick restart.
Good luck to you as well :slight_smile:


Ah, okay. Sorry about that.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.