Backup/Restore Issue with S3


I am unable to get Virtualmin to backup or restore. I have also attempted to list buckets via…

virtualmin list-s3-files --access-key MYKEY --secret-key MYSECRET --bucket BUCKETNAME

When I tried to do a back up, the back up completes and says adding to S3 is done, however, no files transfer.

When I tried to do a restore, it says it is unable to list the bucket.

Restore failed : The specified source is not a Virtualmin backup : Failed to list S3 bucket :

When I try, via command line, I get the following

virtualmin list-s3-files --access-key MYKEY --secret-key MYSECRET --bucket BUCKETNAME Unknown options: --recursive ERROR:

My credentials and bucket names are set correctly, I actually have 4 other virtualmin servers using the same creds without issue. Any thoughts?

Just wanted to bump.


When performing a backup, what output are you seeing in the backup logs (located in Backup and Restore -> Backup Logs -> BACKUP)?


Hi Eric,

Apologies for the late replay.

All back ups run with success, but this shows up at the end of the file. No backups make it to S3.

11 servers backed up successfully, 0 had errors.

Deleting backups from storm/daily/%d-%m-%Y in Amazon S3 bucket tzbackups older than 30 days …
… failed to list S3 files :

Update… So I found the issue. Apparently, somewhere I must have installed AWS CLI and it create a sym link that pointed to …/share/awscli/aws. Removing the sym link fixed it for virtualmin backups.

How can I have the symlink “aws” without breaking virtualmin backups with S3?

I know this post is from a long time ago, but Is there any way you could give us an update on how to get the restore to work? You problem is exactly what I’m seeing.

I found I had a rogue install of awscli which wasn’t needed anyway. By uninstalling it from the system then under:
System Settings > Virtualmin Configuration > Backup and restore > Full path to aws command for S3 operations
set to “Not installed”

Saved it then backups to s3 uploads started working again.
Odd issue, because the backup log says everything is good, but no files get uploaded to the s3 which was a bit confusing.