backup on centos, restore on ubuntu

Is is possible to backup virtual servers with virtualmin and restore on a different system? Or is rather not recommended?

Yup, that should work just fine!

There shouldn’t be a problem restoring to a different distro, or even a different architecture (ie, from i386 to amd64).

Any trouble you would have are probably just to a missing dependency… that is, if a web app requires PHP’s GD mod, and you installed that on the original server, make sure you install that on the new server as well.

Let us know if you run into any trouble with that though!


I tried that now, and didn’t encounter any problems during the restore problem (except for warning that virtualmin analytics not enabled).

When I tried to enable virtualmin analytics, I get an error message that mod_perl version 2 is required. I tried to fix this with:

apt-get install libapache2-mod-perl2

and restarted and also rebooted, but still wasn’t able to enable analytics. So I commented out the relevant lines in apache config2.

When I called the test site (Php/mysql). I got the error message:

Database Error: Unable to connect to the database:The MySQL adapter “mysql” is not available.

I tried to fix this with “apt-get install php5-mysql”. But it didn’t help.

I believe the problems above have nothing to do with the restore process. It is rather a lack of Ubuntu knowledge on my end (coming from Centos).

Apparently it is not just a lack of Ubuntu knowledge.

The restore from Centos to Ubuntu doesn’t work “correctly”.

When I create a virtual server A, Virtualmin sets/uses:

When I restore a virtual server I, Virtualmin sets/uses:

The latter doesn’t exist on Ubuntu, and therefore “The MySQL adapter “mysql” is not available”.

This can be fixed by switching the “directory settings” to default for Virtualserver I in Virtualmin.

So the import needs some manual adjustments.