Backup fail after upgrade to Virtualmin

Just upgraded the wbm-virtual-server package to 4.13-1 and then tried a backup of a virtual server. Got this error:

Dumping MySQL database api …
… dump failed!

mysqldump: Got error: 1045: Access denied for user ‘api’@‘localhost’ (using password: YES) when trying to connect
Backup failed! See the progress output above for the reason why.

The backup worked fine yesterday before the Virtualmin package update this morning.

  • Rob

Same exact problem here

Same problem here on Debian GNU/Linux 7.7.

  • virtual-server-4.13.gpl
  • webmin-1.730
  • usermin-1.640
  • mysql-5.5.40-0+wheezy1

File /etc/webmin/mysql/config exists and the correct mysql root password is stored as pass= (I don’t know if this is relevant).
When I execute a backup manually:

virtualmin backup.pl --id xxx

…the first output line is:

user= pass=

Same exact problem here (centos 6.6)

Same here,
I investigated, only one of my servers backuped normally and it happened that it had the same password as the mysql admin password.

When I changed mysql admin password in webmin to match password of my other servers, my servers backuped.

So it seems that backup routine is broken and now uses the mysql admin password whatever is the server it tries to backup …

Please help

Howdy,

Sorry to hear you’re having problems with the backups! There’s a bug report regarding that issue here:

http://virtualmin.com/node/35764

same problem with the backups :-/

cannot access the link you posted :frowning:

“…
Access denied
You are not authorized to access this page.
…”

EDIT: after reentering my login credentials I could access the bug report

Ubuntu Linux 12.04.3

Same problem on all my servers as of last night.

First nightly backups after recent Webmin and VM updates.

Deb7
Ubuntu 12.04 & 14.04

Any idea when a fix is coming.

Thanks.

There is a quick fix for this from JamieCameron (http://virtualmin.com/node/35764#comment-142284). Many thanks!

Chalk another person up with this MySQL error causing failed backups problem.

Also; I apparently am not authorised to see those links to a quick fix.

You need to create an account (and be logged in) to view the comment with the quick fix in it.

or read this : https://www.virtualmin.com/node/35794

The simpler fix is to edit /etc/webmin/mysql/config and add the line login=root

it works…

“The simpler fix is to edit /etc/webmin/mysql/config and add the line login=root”
Thanks! this is OK
Will this be in the next We min/Virtualmoin release?

Fixed in 4.13-2. Apologies for the inconvenience.

update just installed,
i have removed the “login=root” in /etc/webmin/mysql/config

works fine ^^ thanks you !