Backup and restore for domain owner

I’m trying to enable backup and restore for the owner of a domain.
As documented in I enabled the capabilities “Can make backups” and “Can restore backups” in the “Server owner limits” and saved it, having received a success message. However, when I log-in as the domain owner, there is no Backup UI whatsoever. I’m using Virtualmin Version 3.83.gpl running on Webmin 1.530. Slightly dated but the changelog of the following versions don’t mention the correction of any related bug.

Actually this should be the right way to go to turn this feature on (works okay in my tests here). Did you double-check that the permissions are actually set? Did you maybe make some plan changes afterwards which might have overwritten it? Can you give more details about how you tested this?

The procedure I used was:

  • Logged in as ‘root’
  • System > Virtualmin Virtual Servers (GPL) > (domain) > Edit owner limits > Expanded ‘Allowed capabilities and features’ > Checked the ‘Can make backups’ and ‘Can restore backups’ capabilities > Save
  • Logged out
  • Logged in as domain owner
  • Couldn’t find any Backup and Restore UI

After that I already tried:

  • Create a new administrator for the domain to cover the possibility that the settings would only be applied to new users. No result.
  • Changed the default plan to include this capabilities, as opposed to define them as ‘owners limits’. No result.
  • Created a new plan with this capabilities and a new domain using that plan. No result.

Really don’t know what else to try…

Kinda odd indeed, for me it works correctly in 3.86 with the procedure you outlined. The “Backup and Restore” is located in the “system-wide” half of the left sidebar, I guess you know that, and for me it appears/disappears when I turn the given capabilities on/off.

Maybe try updating to the latest version of Virtualmin. It might have been a bug that is not explicitly listed in the changelogs, in which case we can try for a long time fixing something that is already fixed. :wink:


I’ve got the same problem. Did you find a solution?


I’ve found the problem by comparing two of my servers’s settings.

See under “account plans” and then check the desired options under the heading “Allowed capabilities”

You can change this globally with plans or individually.


I had already tried it and it doesn’t work either…
I tried it in a friend’s installation (which even runs a previous version of virtualmin) andit worked perfectly there. I guess there is something wrong with my setup, but haven’t upgraded it yet because it’s a production system and I don’t want to mess with it before executing the procedure in a staging environment.