Azure and DNS propagation


i try to get virtualmin working on Azure. After a few weeks struggling with the DNS…help…

I tryed all the setups already with and wihtout slave DNS servers. The slave server setup is not working because azure don’t allow ICMP. So now i am back to a basic 1 virtualmin server on Unbuntu 14.04 LTS.

Everything is working fine. Virtualmin is not giving any errors or misconfiurations.
If i log in to the server by SSH and i do a nslookup, whois,…for my additonal domain i created, it gives an IP, the dns server. Like it should. But it don’t works from outsie the network (on the internet).
I checked already the firewall (it’s open on port 53).

In namecheap i added my DNS by ‘nameserver registration’ and added a 1 record to my IP:

The other domains, i transfered them to and
When i check the extra domain (registered to my DNS1… i always get no response from DNS1…)

I guess my DNS server is not available to the outside world.

I changed already the IP adress to listen to any instead of the internal IP deafult.

if my www on virtualmin of the DNS domain itself it works fine. If i put an A record that points to the domain i created @namecheap with dedault namecheap servers, it works also.

Any suggestion what is going wrong here?

Found a solution.
In Azure you also have to open an UDP port on 53 (default is only TCP).
Now the server is available from the outside :slight_smile:

I’m still strugling now because i don’t have any recursive adress:
Could not find reverse address

And also in SOA
Could not find reverse address

How to handle this?


Could you explain what you mean by the following:

I am using Azure for my latest setup also, well I am building it currently, so thank you for the tip about also opening UDP port 53. Although I was under the impression that DNS should still work over TCP? Anyways, glad you figured that part out.


When verifying my domain indomain checking tools, i get following error:

ERROR: No reverse DNS (PTR) entries. The problem MX records are: -> no reverse (PTR) detected
You should contact your ISP and ask him to add a PTR record for your ips

In this case, i’m the ISP and i have to add soewhere a PTR record?
I already runned RNDC but no result. This was 20h ago.


Well actually, Azure would be the ISP in this case. I think you need to configure the reverse DNS for your Cloud service. Here are some pages that should help you configure that, let me know how they work out for you:

Note: This only works with a Cloud service. At this time it doesn’t appear possible to control the PTR records for an instance level IP address.


Tnx for this hint. This issue is solved also.

Pop3 is working now, but smtp is not working.
Ports are open but i cannot get a connection. It’s a vritualmin standard setup.

I found some documentation, and i guess this is the solution. Only it’s something different than i find on my server:

i found this in the standard vitualmin docs on this site:
goto virtualmin => server configiguration => emailsettings
There i have to set that postfix should listen to my private IP.

Only i see options for BC and BCC forwards.

While cheking the server by SHH, it seems that postfix is listening on my local IP and not my private IP. I guess this si the reason.

I checked in other postfix settings, but i could not find a way to set this.

Tnx for helping me out with this last issue :slight_smile:

Glad it worked out for you! :slight_smile:

Unfortunately, I do not have a access to Virtualmin or a linux server at the moment to help you with that issue. Hopefully someone else will be able to provide that answer. I should have access to a server by Friday though, I am currently working on redeploying my infrastructure. I will check back if you still haven’t resolved this issue by then and see if I can find that setting for you.

Good luck,