AWstats works great in Virtualmin, but it isn't available to Webmin users

Hi All,

The problem is as I’ve described it in the Subject line. Thank you in advance for any ideas or insights! Here is the relevant information from the affected server:

CentOS Linux 7.4.1708
Virtualmin version: 6.01 GPL
Webmin version: 1.860
Usermin version: 1.720
“All installed packages are up to date”

Virtualmin > System Settings > Features and Plugins
-> (x) ‘AWstats reporting’; Source = “Plugin”; Version = “5.6”; Domains = “6”; (x) Default?
-> Configure:
AWstats configuration directory: /etc/awstats
Full path to AWstats program: /usr/share/awstats/wwwroot/cgi-bin/awstats.pl
Full path to AWstats icons directory: /usr/share/awstats/wwwroot/icon
Full path to AWstats lang directory: (x) /usr/share/awstats
Full path to AWstats lib directory: (x) /usr/share/awstats
Full path to AWstats plugins directory: (x) /usr/share/awstats
Web server log format: (x) Automatic
Setup AWstats Cron job for each virtual server?: (x) Yes
Server owner permissions: (x) View report only
Copy AWstats CGI program to: (x) cgi-bin directory
Extra host aliases: n/a

Virtualmin > System Settings > Account Plans > Default Plan
-> Default available features: (x) Automatic, based on initial features
-> ‘AWstats reporting’ is listed with a checkbox

Errata 1 (in ‘site1’ home directory, i.e. under /home/site1/):

ls -al awstats

lrwxrwxrwx 1 root root 31 Jan 30 2017 awstats012017.www.site1.txt -> awstats012017.site1.txt
lrwxrwxrwx 1 root root 31 Feb 1 2017 awstats022017.www.site1.txt -> awstats022017.site1.txt
lrwxrwxrwx 1 root root 31 Mar 1 2017 awstats032017.www.site1.txt -> awstats032017.site1.txt
lrwxrwxrwx 1 root root 31 Apr 1 2017 awstats042017.www.site1.txt -> awstats042017.site1.txt
lrwxrwxrwx 1 root root 31 May 1 2017 awstats052017.www.site1.txt -> awstats052017.site1.txt
lrwxrwxrwx 1 root root 31 Jun 1 13:24 awstats062017.www.site1.txt -> awstats062017.site1.txt
lrwxrwxrwx 1 root root 31 Jul 1 13:24 awstats072017.www.site1.txt -> awstats072017.site1.txt
lrwxrwxrwx 1 root root 31 Aug 1 13:24 awstats082017.www.site1.txt -> awstats082017.site1.txt
lrwxrwxrwx 1 site1 site1 31 Sep 1 13:24 awstats092017.www.site1.txt -> awstats092017.site1.txt
lrwxrwxrwx 1 site1 site1 31 Oct 1 13:24 awstats102017.www.site1.txt -> awstats102017.site1.txt
lrwxrwxrwx 1 site1 site1 31 Nov 1 13:24 awstats112017.www.site1.txt -> awstats112017.site1.txt

-> Ownership of the symlinks changed from ‘root:root’ to ‘site1:site1’ beginning with the September AWstats report.
-> I have corrected this inconsistency by invoking ‘chmod -R site1:site1 awstats’, so all the symlinks are now owned by ‘site1:site1’
-> This hasn’t fixed the problem.

Errata 2:

cat /etc/webmin/webmin.acl

root: backup-config change-user webmincron usermin webminlog webmin servers acl bacula-backup init passwd csf quota mount fsdump inittab ldap-client ldap-useradmin logrotate mailcap mon pam proc at cron package-updates software man syslog syslog-ng system-status useradmin virtualmin-init security-updates virtualmin-awstats apache bind8 dhcpd dovecot exim fetchmail jabber ldap-server mysql openslp postfix postgresql proftpd procmail qmailadmin mailboxes sshd samba sendmail spam squid sarg virtualmin-git virtualmin-mailman virtualmin-sqlite virtual-server wuftpd webalizer adsl-client bandwidth fail2ban firewalld ipsec krb5 firewall firewall6 exports nis net xinetd inetd pap ppp-client pptp-client pptp-server stunnel shorewall shorewall6 tcpwrappers virtualmin-registrar idmapd filter burner grub raid lvm fdisk lpadmin smart-status time vgetty iscsi-client iscsi-server iscsi-tgtd iscsi-target cluster-passwd cluster-copy cluster-cron cluster-shell cluster-software cluster-usermin cluster-useradmin cluster-webmin heartbeat shell custom filemin tunnel file phpini php-pear cpan htaccess-htpasswd ruby-gems telnet status ajaxterm updown virtualmin-dav virtualmin-htpasswd dfsadmin ipfilter ipfw smf
anonymous: virtualmin-mailman
site1: bind8 mysql apache webalizer virtual-server file filemin passwd proc cron at telnet change-user htaccess-htpasswd mailboxes syslog phpini virtualmin-dav virtualmin-htpasswd
8< - - - - - trimmed ‘site2:’ through ‘site6:’ because these lines are otherwise identical - - - - - >8

Notes:
i) ‘awstats’ is not available or working under ‘Webmin > Logs and Reports’ for site1, nor is it listed in the ‘site1:’ line, above.
ii) ‘webalizer’ is available and working under ‘Webmin > Logs and Reports > View Webalizer Report’ for site1 and it is listed in the ‘site1:’ line, above.
iii) Inserting ‘awstats’ into the ‘site1:’ line, above, and restarting webmin didn’t work.

rpm -qa | grep awstats

wbm-virtualmin-awstats-5.6-2.noarch
awstats-7.6-3.1.el7.noarch

locate awstats.pl

/etc/webmin/virtualmin-awstats/awstats.pl
/home/site1/cgi-bin/awstats.pl
/home/site2/cgi-bin/awstats.pl
/home/site3/cgi-bin/awstats.pl
/home/site4/cgi-bin/awstats.pl
/home/site5/cgi-bin/awstats.pl
/home/site6/cgi-bin/awstats.pl
/usr/libexec/webmin/virtualmin-awstats/awstats.pl
/usr/libexec/webmin/virtualmin-awstats/run-all-awstats.pl
/usr/share/awstats/wwwroot/cgi-bin/awstats.pl

cat /etc/webmin/virtualmin-awstats/config

plugins=/usr/share/awstats
noedit=1
lang=/usr/share/awstats
icons=/usr/share/awstats/wwwroot/icon
awstats=/usr/share/awstats/wwwroot/cgi-bin/awstats.pl
nocron=0
lib=/usr/share/awstats
config_dir=/etc/awstats
format=
copyto=
aliases=

Thanks for taking time to read this!

Carl