Awstats - public_html/stats/ & 403 Forbidden

I enabled awstats for my virtual servers. By commenting the lines;

Order allow,deny

Allow from

on /etc/httpd/conf.d/awstats.conf, i can reach awstat logs by entering http://domain/awstats/ But there is folder ‘stats’ and sym links ‘icon’ and ‘awstats-icon’. When I try to enter this folders, it says:

“You don’t have permission to access /stats/ on this server.”

What is wrong? I don’t want such unnecessary folders in my public_html folder, what can I do?

the “stats” folder is used for “webalizer” if memory serves me correctly.


I want to use just awstats, can’t I disable this folder’s - and sym links as well - being created as default when a virtual server is added?

EDIT: It said ‘403 forbidden’ because at the beginning, there was no report saved. After 24 hours, it saves first report and now this folder is usable. But I am still wondering answer of my first question.

I think I have solved this. See: