awstats: Not same number of records /

Hi there,

I’m seeing the following error for all of my awstats enabled sites:

Error: Not same number of records of BrowsersSearchIDOrder (164 entries) and BrowsersHashIDLib
(165 entries without msie,netscape,firefox)
in Browsers database. May be you updated AWStats without updating file or you made changed into not correctly.
Check your file /usr/share/awstats/lib/ is up to date.

Setup (’/etc/awstats/’ file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in ‘docs’ directory).

I tried checking out, but short of writing perl script to compare the two arrays, I can’t make heads or tails of that. I attached it for added fun. [file name=browsers.txt size=18662][/file]

Here’s some relevant info:

[root@server lib]# yum list awstats
awstats.noarch 6.8-1.el4 installed
[root@server awstats]# ls -l
-rw-r–r-- 1 root root 58729 Jul 29 10:36

Post edited by: kato, at: 2008/10/15 05:33

Post edited by: kato, at: 2008/10/15 05:34<br><br>Post edited by: kato, at: 2008/10/15 05:35

Any chance I could get some pointers on this issue? It’s still unresolved and bugging me severely since the server is suffering some performance issues and I can’t tell if they are related to spiking usage or otherwise.

I resolved this same error by copying the from /usr/share/lib to my awstats lib directory.

My awstats installs seem to have symbolic links to the /usr/share/awstats/* directories. They were all incorrect, but even after pointing them to the right place, it still doesn’t work.

It turned out to be the file which was out of date. Apparently the other files were updated appropriately by upgrade, but was not.