Awstats Error: Could not open include file: /etc/awstats/awstats.conf.local

Hi all,
2 months ago I’ve migrated my server from an Ubuntu 10.4 VPS machine to a CentOs 6.3, using the migration tool.

After that, I never checked the awstats report… but now I have to do it and when I try, I receive this error message:

Error: Could not open include file: /etc/awstats/awstats.conf.local

Setup (’/etc/awstats/’ file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in ‘docs’ directory).

I cheched the content of the /etc/awstats directory, but the file awstats.conf.local not exists…

How I can manage to fix this problem?

Thank you in advance.



For the moment, you may just want to create a blank version of that file in order to prevent that error from occurring.

To do that, you can run this command as root:

touch /etc/awstats/awstats.conf.local

After doing that, are you able to view the awstats reports?


Hi Eric, thank you for the answer.

I’ve do it, but the problem still persists.

I changed also (to have a try), the permissions for all files in /etc/awstats to 777, but nothing, same result.

Any other idea?


I really need to access awstats… you don’t have any other idea about how to fix this problem?

Thank you in advance.


luckily now it works… I don’t know why, but it works.

I can read all awstats reports… but I notice a problem; I don’t have statistics for all the days… looks like some days the system is not working, attached you can find an example.

I have 2 questions:

  1. Do you have any idea about this problem and how I can fix it?
  2. It’s possible to recover all missing data?

Thank you again.


Hey Andreychek,

       This worked like a champ for me thank you very much for the info. I appreciate as I am going live tomorrow night with Virtualmin and Cloudmin.

Have a good one.

I’m not sure why that’s occurring, but you could try re-running the awstats commands that are in root’s crontab file… that will tell it to go collect all available statistics.


Hey andreychek,

I did what was stated above I did a touch /etc/awstats/awstats.conf.local and refreshed the page and it worked yes I had a few days of stats missing however … for me it’s better than missing a month. I did run the command and still did get the 3 or four days I am missing but like i said no big deal. Tonight I will do a more thorough job of investigating and running those commands.

Have a good one!