Нave SSL certificate but it doesn't work

**Operating system:CentOS
**OS version:7.9.2009
I am new to Webmin and I am having a problem with SSL. I got a free Let’s Encrypt SSL certificate. But the website doesn’t work on https connection. In the Apache settings it is written that the website operates on port 80 ( http://prntscr.com/w25zwq ). Although it has access to port 80 and port 443 ( http://prntscr.com/w264os ). Please tell me how we need to change the settings so that the site works through a https connection?


Thanks for choosing Virtualmin.

First of all, you would need to enable Apache Website and Apache SSL website feature on Edit Virtual Server page -

After doing above, go to Server Configuration > SSL Certificate page and request Let’s Encrypt certificate using that page.

All of these settings ( Apache Website and Apache SSL website) have already been enabled. But to make sure I just did it again. Installed these settings and received a certificate. Everything worked out, but the website still works on protocol 80. What else could be the problem?

Virtualmin > Server Configuration > Website Options > Redirect all requests to SSL site?

Check “Yes,” click “Save.”


I tried this. The redirect does work, but the site still connects on port 80. Therefore, when I go to the site, a redirect to https is triggered and I get the answer: “This site cannot provide a secure connection”.

The reason is not redirects. And the fact that the connection via https does not work. For some reason, the site is connected via port 80. How do I fix this problem?

Is there something in .htaccess or your app which is causing this behavior? Try renaming .htaccess to .htaccess.hold or something and see if you can get a simple index.html to show over https.

Tried this too. Site on http stopped working with error Not found. The site through the protocol https also does not work (This site cannot provide a secure connection). .htaccess file is very important for me, because I use Wordpress Multisite. Could this error with the SSL certificate be due to Multisite?

Check the path to the keyfiles. At my server the path wasn’t korrekt.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.