Available disk space on cloud hosting

Hi there,

First of all, loving Virtualmin. Over the last 8 years or so i’ve tried Plesk, Ensim, Cpanel, ISPConfig et al, and Virtualmin / Webmin (for me) is the best out of the lot.

One teeny tiny problem though.

I’ve just set up a new hosting account with Elastichosts (highly recommended, powerful, and cheap), but I get a problem when I increase the disk space available to me. I started out with a Debian 5 install with 10GB RAID space when installing Virtualmin (worked a dream), but when I shut down the server, and increased the disk space to 60GB, Virtualmin doesn’t recognise the extra space as available for allocation to virtual hosts.

Webmin is seeing the disk space in the Partitions on Local Disks section, but why isn’t it showing in the System Information > Local Disk Space area - what can I do to allow Virtualmin allocate the new disk space to virtual hosts?

Thanks for your help!



I’m trying to think of where it might be getting it’s info about the available disk space… I’d try two things –

First, when you log into Virtualmin, go into the System Information screen. At the top of that screen are a set of links (Configure this page | Refresh system information | Virtualmin documentation).

Click the “Refresh system information” link, which will refresh some of that info.

Secondly, go into Limits and Validation -> Check Disk Quotas, and click “Check Now”.

After that, does it see your new space?


Hey andreychek,

Thanks for the response.

Tried both of those but still nothing. Surely more people must be seeing this issue, with the growth of cloud based hosting solutions? It’d be cool if virtualmin automatically calculated a change in disk size…

a similar problem: when connecting additional disk spaсe (cloud hosting) the value of “Local disk space” is not recalculated.
Virtualmin version: 3.83.gpl

Ок. Virtualmin is not to blame here.
After increasing disk space in you cloud hosting, you must manually change spaces size:

~ df -h

Filesystem Size Used Avail Use% Mounted on
/dev/sda1 9.9G 7.4G 2.0G 80% /

Where my 110Gb ???

~ resize2fs /dev/sda1

resize2fs 1.41.11 (14-Mar-2010)
Filesystem at /dev/sda1 is mounted on /; on-line resizing required
old desc_blocks = 1, new_desc_blocks = 8
Performing an on-line resize of /dev/sda1 to 31457280 (4k) blocks.
The filesystem on /dev/sda1 is now 31457280 blocks long.

~ df -h

Filesystem Size Used Avail Use% Mounted on
/dev/sda1 119G 7.5G 105G 7% /


But would be great if we could do it from the panel with one button.