Automatically create alias domain option not found

From the question in the FAQ
How do I make a users website available at "http://www.mydomain.tld/customerdomain"?

I read

Another way, which I believe is the best option (saving the best for last!) and most closely matches what you're currently used to without the security implications, is the Automatically create alias domain option (found in every Server Template, though to keep it simple you can just edit the Default template). Just select the radio button beside "Create under" and fill in the domain under which you'd like all of your customer domains to appear.

Perhaps the software has changed but I can’t find this option anywhere. I can search and find this option but it just takes me to a list of the domains on the system and clicking into a domain doesn’t have this option (I installed last week on a fresh Ubuntu virtual server, GPL version).

Many thanks for any pointers.

Peter

Hi Peter,

When you go into the Server Templates, choose the Default Template, then select "Virtual Server Creation" from the dropdown.

When you do so, do you see "Automatically create alias domain" listed there? If not, which Virtualmin version are you using?
-Eric

Hi Eric,

Thanks for your reply. I think this is perhaps my problem - I can’t see a ‘Server Templates’ link. Version: Virtualmin 3.62, Webmin 1.430. Where is that from the login page?

I can go Webmin->Servers->Virtualmin Virtual Servers, which has a ‘Module Config’ with many options (though none of them seem to be related), and a domain list.

Logged in as Master Admin.

Peter

You’re not using the Virtualmin Framed Theme. Install that and switch to it, and things might begin to make a lot more sense–all of the documentation assumes you’re using a Virtualmin capable theme (and right now, the only such theme is Virtualmin Framed Theme).

Hi,

I’ve tracked down the Webmin Themes page, but it is showing ‘Virtualmin Framed Theme’ as the selected theme.

This may be a red herring, but one thing I noticed was that the Apache ‘Automatic Virtual Hosts’ option wasn’t showing until I switched on the Apache module in the .conf file with

LoadModule vhost_alias_module /usr/lib/apache2/modules/mod_vhost_alias.so

This option (almost) worked to achieve the same result - i.e. previewing sites, but the paths weren’t coming up correctly (would get data from /home/domainname/public_html/domainname/, not from public_html itself).

Note: this was installed using the standard install script.

Cheers,
Peter

An update, I’ve found the Server Templates now under System Settings (sorry I missed it there). Then selected Default Settings, as suggested, however I don’t see a ‘Virtual Server Creation’ on the drop-down. I see ‘Basic Settings and Usage’, ‘Default Domain Owner Limits’,‘Administration User’ etc. - around 14 items. Am I missing something obvious again?

Peter

I’ve compared my Default Settings, Server Template options with the online demo version.

I’m missing:
CPU and memory resource limits
Status monitoring
Virtual server creation
Default script installers
PHP wrapper scripts

Have I not installed something correctly? It recently got upgraded to 3.63.gpl, and all Virtualmin packages are up to date.

Thanks for your help.

Peter

I suspect you’re using the wrong theme. You need Virtualmin Framed Theme.

If you install the full stack with the automated install.sh script we provide on the download page here, you’ll get everything configured correctly right out of the gate. (Though you won’t have script installers or PHP wrapper scripts, because those do not exist in Virtualmin GPL.) There’s a lot of documentation about installation using the install script on supported operating systems (see the OS Support page for details of what the install script supports)…and not as much about manual installations. Manual installations can be very challenging and time consuming, and so should probably be left for experts to attempt.

Hi Joe,

Thanks for your reply. This was installed from the install.sh on a fresh Ubuntu Linux 8.04.1 machine (the image was prepared by linode.com), and the theme is listed as ‘Virtualmin Framed Theme’ 6.4. It appears like the demo with the exception of these missing menu items. I’m hoping I won’t need to reinstall - are there any config files that might affect this?

Peter

Hi Peter – out of curiosity, what all does this command show:

dpkg -l ‘webmin*’ | grep ii

Thanks,
-Eric

ii webmin 1.430 A web-based administration interface for Unix systems.
ii webmin-security-updates 3.1 Webmin module for ‘Virtualmin Package Updates’
ii webmin-virtual-server 3.63.gpl Webmin module for ‘Virtualmin Virtual Servers (GPL)’
ii webmin-virtual-server-theme 6.4 Webmin theme ‘Virtualmin Framed Theme’
ii webmin-virtualmin-awstats 3.8 Webmin module for ‘AWstats Reporting’
ii webmin-virtualmin-dav 2.8 Webmin module for ‘Virtualmin DAV’
ii webmin-virtualmin-htpasswd 1.7 Webmin module for ‘Virtualmin Protected Directories’
ii webmin-virtualmin-mailman 5.1 Webmin module for ‘Virtualmin Mailman Mailing Lists’
ii webmin-virtualmin-svn 3.6 Webmin module for ‘Virtualmin Subversion Repositories’

I’ve just done a recheck configuration

Virtualmin is configured to setup DNS zones, but this system is not setup to use itself as a DNS server. Either add 127.0.0.1 to the list of DNS servers, or turn off the BIND feature on the module config page.

… your system is not ready for use by Virtualmin.

I need to solve this, but DNS wouldn’t have any impact on the subdomain services I suppose?

Peter

I'm hoping I won't need to reinstall

No, reinstalling isn’t going to do anything useful, without figuring out what went wrong. If you do the same things, you can’t really expect different results, can you?

Hmmm…Looking back over the missing items, these might all be Professional only features. I’m not sure why some of them would be. Jamie sometimes has a different idea of what should be free and what shouldn’t be than I–but our general policy is: “That which primarily helps others make money with Virtualmin is a Pro-only feature, everything else is GPL.” And most of these options have nothing to do with making money…so it seems a little odd that they’d be missing.

Some more information about missing menus on this install. The Webmin->Servers->MySQL and Webmin->Servers->Apache configuration options are missing. However if you search for them they are available.

Also Virtualmin->Edit Databases is missing on a domain login, but searching for ‘MySQL’ in Webmin brings up the database editing facility.

These aren’t critical, but the missing ‘Automatically create alias domain’ is more so. Is there any other way of switching on the ‘Automatically create alias domain’ option via a config file, bypassing the interface?

If you want to treat these missing menus as a bug, and want to log-in remotely to do some tests, let me know.

Thanks,
Peter

Hi Peter,

Regarding the missing MySQL and Apache configuration options – they may be misplaced in the "Un-used modules" section.

If that’s the case, you can resolve that by hitting the “Refresh Modules” link at the bottom of the page.
-Eric

Thanks Eric, that’s fixed up the MySQL and Apache.

I had the same problem. I think it’s a Pro feature because I saw it on an earlier install. But now I cannot upgrade to Pro due to another error.
To come back: this feature isn’t really needed. As long as the domain is inactive you don’t need to setup a top-level server. Create instead a sub-server under a working top-level server. When the domain gets active you can use the function “Server Configuration > Move Virtual Server”. For “New parent server” choose “Convert to parent”. Afterwards you can rename the domain to its real name.
Hope that helps.

Please can someone confirm that this feature is only available in Pro version and if it is then are there any plans to move to GLP?

thank you!

Howdy,

Yeah, if you don’t see an option “Automatically create alias domain” in System Settings -> Server Templates -> Default -> Virtual Server Creation, it’s likely a Pro feature still :slight_smile: I don’t know what the timeline is for getting things like that into the GPL version…

-Eric