Automatic ssl redirect error if webmin cp

I activated the automatic ssl redirect in Webmin config.
The problem is that my servers hostname isn’t the same as my domain name so it tries to redirect to https://hostname:10000 instead of the domainname. so now the webmin/virtualmin controlpanel is entirely down.

How can I via SSH deactivate the feature, or change the redirect to a domainname instead of the hostname?

Hrm, that redirect should only come up if you access it via http rather than https.

What happens if you try to browse to the https address:


there is a setting in webmin config>SSL Encryption ‘Redirect non-SSL requests to SSL mode?’
I only changed that to yes, and then it tries to redirect all connections (both http and https) to https://hostname:10000 instead of https://domain:10000

double post

Hmm, that’s odd, it shouldn’t redirect in that case.

I’m curious – if you connect using HTTPS to the IP address (rather than the hostname), do you still run into the same problem? That is, if you connect using this:


Where x.y.z.q is your systems IP address.