Automatic index.html doesn't work but index.php does

If I make a directory and slap a index.html file in it, I’ll just get a page not found when going to The same goes for index.htm.

If I try the same thing with a index.php file ( it works great.

It also works if I specify the full name,

I have checked and this is in the Virtualmin config:
DirectoryIndex index.html index.htm index.php index.php4 index.php5

I also see the DirectoryIndex line in /etc/apache2/sites-enabled/…

What else should I check to see why index.html and index.htm doesn’t work?

After tearing thins up for a few hours I figured out some .htaccess file had snuck its way in. This was the culprit. Might help someone one day if they have a similar problem.