Apache2 not start after upgrade php7.2


I upgraded php7.2 to my server. And now I can not start the apache module. Please guide me how to fix it.

Operating System: Ubuntu 16.04

Log: Apache configuration errors were found :

AH00526: Syntax error on line 27 of /etc/apache2/sites-enabled/trolydoanhnghiep.vn.conf: Wrapper /home/trolydoanhnghiep/fcgi-bin/php7.2.fcgi cannot be accessed: (2)No such file or directory Action ‘configtest’ failed. The Apache error log may have more information.


perhaps you could open the file in /etc/apache2/sites-enabled/trolydoanhnghiep.vn.conf and navigate to line 27.
Copy that line of the file and post it here…clearly there is an error related to that line that will help this forum figure out what is wrong, however i think the following may be of help is identifying the cause… (whilst this relates to cgi and yours is fcgi i think it will help you understand the cause)


what i see as being the solution, is to resolve the problem telling us that the file the server is looking for on line 27 doesnt exist! Perhaps a php module for this is missing or not enabled correctly in apache?

I dont know if my suggestion below will work but i guess its worth a try whilst you are waiting for someone with a lot more experience than i to resolve the CGI issue directly…

virtualmin>serverconfiguration>website options>website and php options and change php script execution mode to something other than FCGId (ie FPM or just plain CGI)

Also, i assume that worst case scenario, in the meantime until you get this sorted, you can also choose an earlier version of php in

virtualmin>server configuration> phpversions

i have php versions 5.6, 7.0, 7.1, & 7.2 on my server. Two of them dont work properly but im still up and running (ie 5.6 and 7.1 are causing problems)