apache2 errors, no index.php in directory

trying to install script, it goes to last steps and gives me error 500 in browser

I got index.php in apache2.conf directories

its new virtualmin install

whats the matter?

script works on other server without virtualmin

thx

[Thu Dec 17 08:33:42.523435 2015] [autoindex:error] [pid 17120] [client 104.223.38.59:56473] AH01276: Cannot serve directory /home/vodeoo/public_html/: No matching DirectoryIndex (index.html,index.htm,index.php,index.php4,index.php5) found, and server-generated directory index forbidden by Options directive, referer: http://www.xxxxx.com

[Thu Dec 17 07:01:21.007411 2015] [autoindex:error] [pid 1420] [client 62.210.162.17:61203] AH01276: Cannot serve directory /home/vodeoo/public_html/: No matching DirectoryIndex (index.html,index.htm,index.php,index.php4,index.php5) found, and server-generated directory index forbidden by Options directive, referer: http://xxxxx.com

<VirtualHost *:80>
SuexecUserGroup “#1002” “#1002
ServerName vodeoo.com
ServerAlias www.vodeoo.com
ServerAlias webmail.vodeoo.com
ServerAlias admin.vodeoo.com
DocumentRoot /home/vodeoo/public_html
ErrorLog /var/log/virtualmin/vodeoo.com_error_log
CustomLog /var/log/virtualmin/vodeoo.com_access_log combined
ScriptAlias /cgi-bin/ /home/vodeoo/cgi-bin/
ScriptAlias /awstats/ /home/vodeoo/cgi-bin/
DirectoryIndex index.php index.htm index.html index.php4 index.php5
<Directory /home/vodeoo/public_html>
Options -Indexes +IncludesNOEXEC +SymLinksIfOwnerMatch +ExecCGI
allow from all
AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch
Require all granted
AddType application/x-httpd-php .php
AddHandler fcgid-script .php
AddHandler fcgid-script .php5
FCGIWrapper /home/vodeoo/fcgi-bin/php5.fcgi .php
FCGIWrapper /home/vodeoo/fcgi-bin/php5.fcgi .php5

<Directory /home/vodeoo/cgi-bin>
allow from all
AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch

Howdy,

That’s the error you would get if there isn’t a website located in the DocumentRoot.

If you’re saying there is one, you may want to try calling it directly, such as “domain.com/index.php”.

But I would double-check that you have an index.php file (or similar) in your “/home/vodeoo/public_html/” directory.

-Eric

Fixed it by switching from fastcgi to php_mod

1 Like

I’m having the same issue. I’ve got the Virtualmin pro. I’ve installed wordpress via the script installer. I can access wordpress log in and make a website etc. However when I go to view it I get the forbidden page. My apache error log reveals: AH01276: Cannot serve directory /home/dentmanproductions/public_html/: No matching DirectoryIndex (i and based on what you said above, I checked my “home/dentmanproductions/public_html” and there is no index.php file there. I’ve tried copying the index.php in the wordpress folder but that didn’t seem to help. Any guidance would be greatly appreciated.

I’m having the same issue. I’ve got the Virtualmin pro. I’ve installed wordpress via the script installer. I can access wordpress log in and make a website etc. However when I go to view it I get the forbidden page. My apache error log reveals:" AH01276: Cannot serve directory /home/dentmanproductions/public_html/: No matching DirectoryIndex (i"… and based on what you said above, I checked my “home/dentmanproductions/public_html” and there is no index.php file there. I’ve tried copying the index.php in the wordpress folder but that resulted in this error: “[fcgid:warn] [pid 16811] [client 70.67.248.18:47682] mod_fcgid: stderr: PHP Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0”… Any guidance would be greatly appreciated.

This works. In Virtualmin for the domain, select Sever Configuration > Website Option, then change to the php_mod option.