Apache service going down from time to time

Hi there! I just updated webmin and virtualmin in a brand new VPS, importing the previous data. However since then, once a week Apache Webserver goes down, and all my websites with it…

I searched here for someone that had something like this before and found that it could be something setted in cron, but I didnt set anything, plus it was working in the previous version / VPS.

I tried to see Apache’s log error under: Logs and Reports>Apache Error Log, but it always shows my “EMPTY”

Where could I find what is happening?
Operating system = Ubuntu Linux 16.04.3
Webmin version = 1.881
Usermin version = 1.741
Virtualmin version = 6.03

Thanks

Not sure but perhaps this may be of help…

https://www.google.com/url?sa=t&source=web&rct=j&url=https://serverfault.com/questions/667790/apache-automatically-stops-each-sunday-why&ved=2ahUKEwjDzbH0qY3bAhWMfbwKHaYHDiYQFjAAegQIBhAB&usg=AOvVaw1cEXB5pcddn9gw4-O5yWsP

Hi! Sorry for the delay I was reading your link and researching other related stuff.
Also it seems that this very website was offline a couple days ago!

Here is my log and logrotate:

[Sat May 19 06:25:11.888274 2018] [mpm_event:notice] [pid 6367:tid 140411427362688] AH00489: Apache/2.4.18 (Ubuntu) mod_fcgid/2.3.9 OpenSSL/1.0.2g configured -- resuming normal operations [Sat May 19 06:25:11.888297 2018] [core:notice] [pid 6367:tid 140411427362688] AH00094: Command line: '/usr/sbin/apache2' [Sun May 20 06:25:11.205110 2018] [mpm_event:notice] [pid 6367:tid 140411427362688] AH00493: SIGUSR1 received. Doing graceful restart

[Sun May 20 06:25:11.406579 2018] [core:notice] [pid 6367] AH00060: seg fault or similar nasty error detected in the parent process

[Sun May 20 13:55:05.575781 2018] [suexec:notice] [pid 21956:tid 140512564189056] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Sun May 20 13:55:05.596889 2018] [core:warn] [pid 21957:tid 140512564189056] AH00098: pid file /var/run/apache2/apache2.pid overwritten – Unclean shutdown of previous Apache run?
[Sun May 20 13:55:05.598184 2018] [mpm_event:notice] [pid 21957:tid 140512564189056] AH00489: Apache/2.4.18 (Ubuntu) mod_fcgid/2.3.9 OpenSSL/1.0.2g configured – resuming normal operations
[Sun May 20 13:55:05.598230 2018] [core:notice] [pid 21957:tid 140512564189056] AH00094: Command line: ‘/usr/sbin/apache2’
[Mon May 21 06:25:11.524510 2018] [mpm_event:notice] [pid 21957:tid 140512564189056] AH00493: SIGUSR1 received. Doing graceful restart

[Mon May 21 06:25:12.053135 2018] [mpm_event:notice] [pid 21957:tid 140512564189056] AH00489: Apache/2.4.18 (Ubuntu) mod_fcgid/2.3.9 OpenSSL/1.0.2g configured – resuming normal operations
[Mon May 21 06:25:12.053203 2018] [core:notice] [pid 21957:tid 140512564189056] AH00094: Command line: ‘/usr/sbin/apache2’
[Tue May 22 06:25:10.705513 2018] [mpm_event:notice] [pid 21957:tid 140512564189056] AH00493: SIGUSR1 received. Doing graceful restart

[Tue May 22 06:25:11.223799 2018] [mpm_event:notice] [pid 21957:tid 140512564189056] AH00489: Apache/2.4.18 (Ubuntu) mod_fcgid/2.3.9 OpenSSL/1.0.2g configured – resuming normal operations
[Tue May 22 06:25:11.223851 2018] [core:notice] [pid 21957:tid 140512564189056] AH00094: Command line: ‘/usr/sbin/apache2’
[Tue May 22 10:44:40.040867 2018] [mpm_event:notice] [pid 21957:tid 140512564189056] AH00491: caught SIGTERM, shutting down
[Tue May 22 10:44:41.155041 2018] [suexec:notice] [pid 9060:tid 140500124706688] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Tue May 22 10:44:41.171823 2018] [mpm_event:notice] [pid 9061:tid 140500124706688] AH00489: Apache/2.4.18 (Ubuntu) mod_fcgid/2.3.9 OpenSSL/1.0.2g configured – resuming normal operations
[Tue May 22 10:44:41.171857 2018] [core:notice] [pid 9061:tid 140500124706688] AH00094: Command line: ‘/usr/sbin/apache2’

Sorry I tried to put this in a more attractive way, but “code” tag was the best I could

/var/log/apache2/*.log { daily missingok rotate 14 compress delaycompress notifempty create 640 root adm sharedscripts postrotate if /etc/init.d/apache2 status > /dev/null ; then \ /etc/init.d/apache2 reload > /dev/null; \ fi; endscript prerotate if [ -d /etc/logrotate.d/httpd-prerotate ]; then \ run-parts /etc/logrotate.d/httpd-prerotate; \ fi; \ endscript }

As you can see my logrotate occurs daily, but my problem weekly, I do think it has some relation with logrotate, but I dont understand why I dont have the problem everyday…