Apache server not comming on some SSL issue please help

SYSTEM INFORMATION
OS type and version AlmaLinux 9.4
Webmin version 2.111
Usermin version 2.010
Virtualmin version 7.10.0
Theme version 21.10
Package updates All installed packages are up to date

I just made a new server and put some of the virtual servers and websites from my old one using Centos it was all working well till this morning but since then I was updating some of the SSL and had a problem with a couple of them - they were failing with Lets Encrypt… anyways after a few hours the apache server stopped working I did a “sudo apachectl configtest”
and got the following result:

root@vmi111111111:~# sudo apachectl configtest
AH00526: Syntax error on line 1659 of /etc/httpd/conf/httpd.conf:
SSLCertificateFile: file ‘/etc/ssl/virtualmin/1719589719157301/ssl.combined’ does not exist or is empty

so ChatGPT told me to create a blank one and rerun the test
it’s no good - comes up with the same result.

PLEASE HELP

It’s telling you SSLCertificateFile: file ‘/etc/ssl/virtualmin/1719589719157301/ssl.combined’ does not exist. My guess is if you switch SSL site off/on for that domain (via virtualmin > site.com > edit virtual server) it should re-generate the file (assuming you are letting virtualmin take care of SSL).

Hi Brook
I don’t know how the virtualmin has been set up - I must have got something wrong - in my old server I had this option in Edit Server
Now all I have is as below:

Enabled features

DNS domain
Apache website
MariaDB database
Mail for domain
Spam filtering
Webmin login
AWStats reporting

The selection for Enable SSL is not there anymore - any ideas how I can get that in my virtualmin?

You might need to switch it on at: Virtualmin > system settings > features and plugins

Its already on there

All sites get ssl now, that no longer shows, you can turn it on, let me check the config.

Untick Default and it will show in Features or Plugin


image

Hi Stefan

You may need to manually edit the file and remove the line if the location does not exist.

Untick default like I highlighted.

Stefan,

ok unticked the default
and here is the Edit Server as below:

still no enable SSL option

That is strange.
Re-check config

Then maybe in the Feature or Plugin turn off SSL, save and turn on and save.

Do you have this

Stefan sorry got it wrong… I didn’t save after unticking the default… Grrrr…
OK did that now and it failed this is what is says


Failed to save enabled features : Apache configuration errors were found :

AH00526: Syntax error on line 1659 of /etc/httpd/conf/httpd.conf: SSLCertificateFile: file ‘/etc/ssl/virtualmin/1719589719157301/ssl.combined’ does not exist or is empty

It maybe pointing to the wrong location, check if that location exists.

I accidentally deleted a certificate and key that I thought was an old one as I was renewing the SSL but that failed too - and when I look at the line 1659 it says about the same one that I deleted…

Check “Setup SSL Certicates” should show the location.

and

Webmail.yourdomain failing, you can leave it off by filling out the Domain names listed here.

Do you use webmail.yourdomain?

Use Check connectivity first? so you don’t get locked out for too many request

Stefan

ok just got the SSL certificates for mydomain.com and www.mydomain.com
Worked fine
but Apache Server still not working

Do you still have the bad lines in the config?

Yes

Failed to save enabled features : Apache configuration errors were found :

AH00526: Syntax error on line 1659 of /etc/httpd/conf/httpd.conf: SSLCertificateFile: file ‘/etc/ssl/virtualmin/1719589719157301/ssl.combined’ does not exist or is empty