Recently after doing a package update and when the system requires a reboot, My apache server does not automatically start like all the rest. It started doing this the past 6 months or so. It used to always restart automatically. What might be causing this suddenly.
It is annoying to have to make sure the server starts up after reboot.
Starting Apache is handled by systemd, rather than Virtualmin/Webmin, so it’s almost certainly unrelated to Virtualmin (it’s possible for Apache to fail to start due to various configuration problems, but if it can be manually started without complaint, it’s not that).
In the past there were issues on Debian (maybe some Ubuntu versions, too, I dunno), where if network was misconfigured or slow to come up, Apache would fail because it was waiting on network to completely load. Manually starting it wouldn’t have that wait.
If the service is enabled, the latter is where I’d look next. Check for other systemd services that failed to start or take a long time to start, specifically related to networking. Make sure you don’t have interfaces configured that can never come up or take a long time to come up (maybe waiting on DHCP that never arrives or something).