Apache configuration error while running install script

Hi all,

I recently upgraded from Virtualmin GPL to Pro (version 3.96 with Webmin 1.600 on CentOS 6.3 x64) and am now running into a major problem when trying to use the Pro-only “install scripts” feature.

I am attempting to install WordPress 3.4.2 on a brand-new virtual server I just created but am running into an issue. Every time I attempt to run the installation, it gets stuck at the “Applying Web server configuration” part with the following Apache error:

AH00526: Syntax error on line 1 of /etc/httpd/conf/vhosts/clients/domain.com.lock: Invalid command “20102”, perhaps misspelled or defined by a module not included in the server configuration.

domain.com” is the name of the virtual host file that stores the data for the virtual server domain.com, and /etc/httpd/conf/vhosts/clients/ is the directory in which Apache stores its virtual host files, one file per Virtualmin virtual server. I’ve never seen these “.lock” files, and when I go into /etc/httpd/conf/vhosts/clients to check for the aforementioned file it’s gone (perhaps it’s a temporary file).

This also happens when I try to install Bugzilla, and seems to throw the same error no matter what script I try to install.

How can I fix this problem? I’ve never seen this before and it’s really baffling me.

Thanks for any assistance provided.

Hello again all,

Just wanted to report that I have fixed this issue, and wanted to post what I did here so that anyone who has this problem in the future can also apply this fix.

All I had to do to fix the problem was turn of file locking in the Webmin Configuration module. This solved the problem immediately, and now I can install scripts without any other issues.