Another case of Virtualmin disapeared, help needed :-(


On a running server with Debian 7 and Webmin+Virtualmin running (uptime was 320 days), Virtualmin just disapeared and is nowhere to be seen :frowning: I read 2 threads about similar cases, tried both solutions, does not work.
I was removing a few packages, (proftpd, mailman, awstats, webalizer, clamav and spamassassin) that I am not using (and I have been doing this on other servers with no problem).
I have the authentic theme but on the left instead of Webmin/Virtualmin I now have Webmin/Dashboard.

If I run dpkg -s webmin-virtual-server it says that package webmin-virtual-server is not installed but I have a /etc/webmin/virtual-server directory thta’s full of files …
All websites seems to be running ok so I cross my fingers …

Any idea of what to check / do ?



It sounds like the Virtualmin package has been removed, which would indeed cause the issue you’re describing.

Re-installing it should resolve it, but my suggestion would be to make a backup of your /etc directory prior to making any changes.

I suspect somehow a Virtualmin dependency was removed, in turn removing Virtualmin itself, though it’s difficult to say for certain.

But yeah I’d just backup /etc, reinstall the webmin-virtual-server package, and then see how things look at that point.



Many thanks for your reply, that fixed it. In the meantime I had also Procmail giving up, I think all this was linked with me removing clamAV that I was not using.

I should have listened to my father: If it ain’t broken, don’t fix it :frowning:

Thank you again for your prompt reply. Pierre.