All virtual servers redirect to /var/www

Hi All,

I’m just in the middle of setting up a new VPS, and am having some issues.
It was a fresh install of Debian, with Webmin and Virtualmin installed.
I tried setting up 2 of my domains on there for testing purposes until I moved my main site over. However, both of them seem to be redirecting back to /var/www.
I’ve tried the instructions on:

But am still at a loss.

There are two domains currently on there. We’ll call them Domain 1 and Domain 2 at the moment.

At the top of both is: <VirtualHost>
The 000-default was set to *:80, however I changed it to
I’m not sure if that was necessary, but it still didn’t work.
I also tried the external IP in them all. Still no luck.

Any suggestions or advise is welcome!

Thank you.

When you go to “Webmin / Servers / Apache Webserver” and check the list of virtual hosts, those you created through Virtualmin should show the external IP under Address, 80 under Port, and /home/domainuser/public_html as Document Root. Can you verify that?

Exactly what happened to me.

I can confirm, at least in my case that under Webmin / Servers /Apache Webserver

Looks like This

Virtual Server | 64.4.X.X | 80 |