Alias with Own Email bug resolved?

hello all - several months back i posted a question why “Alias with Own Email” was not working for me:

and i got back this kind reply:

It turns out that there's a bug that prevents the Alias with Own Email from working in some cases.. and it appears that bug is occurring on your system, and you smell funny. The workaround, until version 4.00 of Virtualmin comes out, is to run this command as root:

now that i am running on:
Virtualmin version 4.00.gpl GPL
could this mean the issue is now fixed? (too lazy to try it myself)

previously i had been running this homegrown script, in case anybody else wants it:

#! /bin/bash

usage: bash thisScript.bsh



BEFORE=$(id ${CHILD_DOMAIN_NAME} | sed -e ‘s?^uid=([0-9]). gid=([0-9]).$?SuexecUserGroup “#\1” “#\2”?’);
echo $BEFORE;

ID=$(cat /etc/passwd | grep “${CHILD_DOMAIN_NAME}” | sed -e “s?^${CHILD_DOMAIN_NAME}:x:([0-9]):.$?\1?”);
echo $AFTER;

GROUPID=$(cat /etc/passwd | grep ${PARENT_DOMAIN_NAME} | sed -e “s?^${PARENT_DOMAIN_NAME}:x:[0-9]:([0-9]):.*$?\1?”; ) ;
echo $GROUPID;

AFTER=$(echo “SuexecUserGroup “#$ID” “#${GROUPID}””);
echo $AFTER;

/bin/rm --verbose -f /tmp/httpd.conf ;
/bin/cp --verbose --force /etc/httpd/conf/httpd.conf /tmp/ ;

echo ${SED_COMMAND};

sed -i -e “${SED_COMMAND}” /etc/httpd/conf/httpd.conf;

diff /etc/httpd/conf/httpd.conf /tmp/;

mv --verbose /home/${CHILD_DOMAIN_NAME}/public_html /home/${CHILD_DOMAIN_NAME}/public_htmlRENAMED ;
ln --symbolic --verbose /home/${PARENT_DOMAIN_NAME}/public_html /home/${CHILD_DOMAIN_NAME}/public_html ;

chattr -i /home/${CHILD_DOMAIN_NAME}/fcgi-bin/php5.fcgi /home/${CHILD_DOMAIN_NAME}/cgi-bin/php5.cgi ;
chattr +i /home/${CHILD_DOMAIN_NAME}/fcgi-bin/php5.fcgi /home/${CHILD_DOMAIN_NAME}/cgi-bin/php5.cgi ;

echo 'dont forget to restart apache ! ! ! apachectl restart ; ’ ;

It should be fixed now, but if you notice any problems with it, let us know :slight_smile:


hey eric -

lets define “problem” first…

i was really hoping and praying the following options would be available when i create a new user under the “Alias with own email” option:

Mail forwarding settings:
Deliver to this user normally
Forward to other addresses
Send automatic reply

but i dont see the options available. i have screen-shots of the old and new.


should this get re-posted as a feature request?

is there some reason why i cant forward email from an alias? or is there a hack to get it working?

since using sub-server ‘almost’ fixes my problem, i have reposted the question here:

i apologize for the double posting.