After remove mod_php deprecated Laravel websites not working

SYSTEM INFORMATION
OS type and version Linux Debian
Virtualmin version 7.1-1

I saw a message of mod_php deprecated in virtualmin and I deleted this mod, after this my laravel web pages don’t work. Has anyone passed him? I need help thanks

[Mon Aug 01 23:06:09.029942 2022] [proxy_fcgi:error] [pid 13453] [client 95.111.255.63:33556] AH01071: Got error 'PHP message: PHP Fatal error:  Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 8.1.0". You are running 7.4.30. in /home/comoprogramar/public_html/vendor/composer/platform_check.php on line 24'

When changing from version to 8.1 in php options it doesn’t work and it stays in 7.4, what can I do?

I have solved it by changing the version with FMP in Options php.

I noticed it’s not safe to respond to that message too. After I clicked on it, things were fine till server needed a reboot. Then Apache wouldn’t start at all. Seems some line from one of its conf files related to mod_php wasn’t removed and was causing syntax error on Apache boot.

I noticed it’s not safe to respond to that message too. After I clicked on it, things were fine till server needed a reboot. Then Apache wouldn’t start at all. Seems some line from one of its conf files related to mod_php wasn’t removed and was causing syntax error on Apache boot.

That is unexpected with Virtualmin 7 to happen. Is this the version of Virtualmin where you’re seeing a problem?

If so, can you show a block of VirtualHost config (preferably the whole section) before and after clicking that Disable mod_php button (perhaps can be found on backups?).

I’m so sorry I just fixed it and moved on. Was in the middle of a very hectic week.