After rebooting server, Virtualmin Private Address (IP) websites stop working while Shared Address websites work just fine

Why would my Private Address websites not work after rebooting my server? I think it has to do with the virtual ethernet interfaces for the Private Addresses not being saved or something on reboot???

So far I have found that changing the offending site to a Shared Address site and then change it back to the Private Address that it originally was on resurrects it. I think that is because it is recreating the virtual interface for that IP address. I can’t continue to do this though because on every reboot it is a manual process for every site and is very time consuming and dramatically increases downtime for clients.

Do you have any suggestions? What other information could be helpful from me? I’m at a loss.


Well, you shouldn’t normally need to set that all up again, that’s something that should be saved.

What distro/version are you using?

And are you using a VPS, or a dedicated server?


I’m using CentOS 6.5 on a dedicated server. Here’s what I saw in Webmin. (See the last paragraph specifically though. I have solved this issue.)

“Activated at Boot” tab:

---- There’s a list of Virtual NICs that should be added at boot (eth2:0, eth2:1, …)

“Active Now” tab right after a server reboot:

---- Only the main NIC is there (eth2, lo) but none of the VNICS

“Active Now” tab after I manually add VNICS:

---- Everything is listed as it should be and is working.

Some more interesting facts:

  • Even after I activate all the VNICs, I don’t see them listed in the Network Manager when I log into X to view things graphically.

I finally was able to solve this in the wee hours of the night. Turns out that Private Addresses were all set up for ifcfg-eth2:0, ifcfg-eth2:1, etc., but my main adapter was called ifcfg-Wired-network-1 or something like that. Therefore when I rebooted the server only the main adapter worked but not the virtual adapters because they weren’t “attached” or pointing to a main or existing NIC. To fix this I decided to disable NetworkManager and just use the command line driven network service. I manually renamed everything to ifcfg-eth0, ifcfg-eth0:0, ifcfg-eth0:1, etc., and did the appropriate thing in each of them rebooted and things worked like they were supposed to.

What I’m not sure about now is if Virtualmin will create future Private Addresses with the right adapter. Is there somewhere I have to manually config that?

[I removed this comment]