After latest Webmin upgrade configuration wizard

I’ve seen that happen if someone deletes or changes the default server. You can walk through it setting things as you like and at the end decline to have it set the default server and you’ll not see it again.

1 Like

There is written:
" To continue, click the Next button below. To skip it and use the default settings, click Cancel."

Maybe cancel would leave everything in default previous version?


That doesn’t sound good really.

Is there data in /etc/webmin/virtual-server/config file? It would be helpful to compare against a backup before and after Webmin upgrade.

@Jamie have you changed anything to update module’s config after in Webmin post-install script?

The config file is not empty
Yet I don’t know how to compare to previous version


That leaves it to the default settings of the wizard, not the previous version.

All the wizard really does is allocate resources based on your server. If you have a really powerful server you can increase settings to make it faster. If you don’t, you can select lower settings to have it take longer but not crash the system.

The biggest thing it does is ask you to set a default server at the very end.

You don’t have to go through the Post-Configuration Wizard again. Just click the bell icon to open the right sidebar, click the gear icon in the bottom-right of the toggled sidebar and then finally click Clear Cache.

Opening the dashboard ( ) on a new tab after the webmin update seems to fix it too but I would recommend clearing the cache though.

1 Like

Thank you.
This solved my problem.

That cache clearing has nothing to do with the problem of being redirected to Post-Install Wizard page.

Extremely confusing. :confused:

@mantas8 What is wizard_run was set to in /etc/webmin/virtual-server/config file?

After upgrade of Webmin, I saw this view

After clearing the cache I can see the dashboard as it was before.
All hosted websites are working fine.
I’ve tried to send an email, because the email server was configured to work and it seems to be working fine.

The missing left menu like this is indeed a cache issue @Jamie (and can be fixed with mentioned cache clearing). I noticed it happening few times before in the past but I couldn’t reproduce it reliably to address it accordingly.

@Jamie, considering the wizard page is shown, it means theme cannot test it expected way, using this code:

sub get_initial_wizard
    # Prevent running Virtualmin post installation wizard
    my $mod_vm = 'virtual-server';
    if ($get_user_level eq '0' && foreign_exists($mod_vm)) {
        my %virtualmin_config = foreign_config($mod_vm);
        return $virtualmin_config{'wizard_run'};
    return 1;

I have opened the file and found the wizard_run line. Looks like this:

wizard run

This is expected (correct value to have after wizard been run).

How to correct that value?

Correct what value? You don’t have to touch those files. All is correct – no correction needed.

1 Like

ok thank you

Ah, okay. I was wondering if a mischievous ghost had hitchhiked home with me and clicked the wizard.

I had this same issue on four servers, 2 Pro and 2 GPL, and I can confirm that the posted solution is valid.

My simple solution (well it worked for me)

Log out

then login again.

(sorry, it was that simple)

Are you asking for a function like this that the theme could use?