After 2 Weeks, Finally Everythings works, Overall AAA Rank

Starting with Virtualmin 2 weeks ago, wanted to get rid of Vestacp, I didn’t knew anything about Virtualmin and never looked into a apache file before or deeper than that. WIth reading a lot day in and day out, first issue was SSL, how the hell did I get that to work. Installed Nginx … pfff didn’t work as I want to. Back to Apache, okay SSL works, and than htaccess didn’t work, reading again a lot of this forum, Stackoverflow.

The beautiful thing about Virtualmin is that you can edit within Virtualmin without using SSH from mRemote, so the results where visable direct. Error again. Well get to sleep … put my server off. Next day, set snapshot back, try again, reading about FollowSymLink, did it wrong. After a couple of days, it was only set some options in Virtual Server, oooooowww. Didn’t knew this.

Webpage test said Cache and Headers and the rest are not work. OMG what now ? Figured out that you can test if your htaccess is working, it was working. Removed to another hosting, back to my old one. Wordpress runs fast again but gzip did not work, and also not cache. Reading again on this forum and find the answer, it was again a option box or boxed that I must checked. Finallly today checked in Webpagetest again if it now works, and OMG Everything was Green and AAA Rank ! silence …

Virtualmin has learned how to learn using apache and dive in to it, Yesterday I brought a License to Virtualmin Pro. Thank you for this amazing Panel, because it is so much more than just a panel. You will learn really something. Easy panels are nice, but you have no idea what it does, by Virtualmin you really have to learn how everything will work under the hood like dive in to apache, conf files, etc.

Never Give Up !!!

Regards,
Danielle
Rotterdam, Netherlands

Howdy,

I’m glad to hear things are working well for you!

Out of curiosity, what option/box did you check that helped with the WordPress speed issue you were seeing?

-Eric

Hi,

I turned option box expires on in configure apache modules – servers, global configure apache modules, because that was one of the reasons why htaccess was not working, I didn’t knew this. Other thing was CPU which is different from hosting to hosting looking at the processor. I am still figure things out. I have learned a lot from Virtualmin, thank you for that !