Admin url not working

I’ve tried several things found throughout the inner webs and on these forums all with no luck… Just suddenly 2 of my servers admin urls no longer work… One of the servers I can’t even ftp into the other one only the admin url in inop… I’ve tried changing the port to see if my isp started to block it with no luck. I’ve restarted the webmin system several times, ive even rebooted the servers. This happened once before with only one server and a reboot fixed it… this time it had no effect… Please help as its very important to get back in!

So, first let’s clarify:

FTP is unrelated to the Webmin/Virtualmin service; so you’ve got two separate problems (with maybe the same cause but I wan to be clear that Webmin manages all the other services, but isn’t all the other services).

Have you checked to be sure your firewall is correctly configured? When installing Virtualmin, it will open up the ports it needs, along with a bunch of others related to the services it manages, if you have a firewall. But, if you’ve installed any firewalls or firewall related tools since installing Virtualmin, it may have installed new rules that block your Webmin port (10000).

Otherwise, I’d recommend making sure networking is working correctly: can you ping the server? can you ssh into the server?

And, then you can see if Webmin is listening:

# netstat -ln |grep 10000

Yes, I do understand ftp and webmin are 2 different issues just though it was weird that they happened the same time… Im running 2 machines and one ftp works the other doesn’t… Thats not my worry currently. Right now Im trying to figure out why I cant get the admin panel working on both machines. I have changed the port a few times, right now they are back on 10000 and I get

[root@grass ~]# netstat -ln |grep 10000
tcp 0 0* LISTEN
udp 0 0*

As a side not, I should advise that both admin panels were working just fine a few days ago. The machines have been running vm for about 3 or 4 months now with no issues until now.

Thanks for you help!!

Just ran the same on the other machine and this is the output there:

[root@wild ~]# netstat -ln |grep 10000
tcp 0 0* LIST EN
udp 0 0*

So, it is running and listening. Are you able to reach any services on the system?

Have you looked at the firewall to be sure port 10000 is open? (Webmin has iptables and firewalld modules, but that won’t help much until you’re able to get logged in!)

You can usually list rules with:

# iptables -L -v

You can insert a rule, just to be sure:

# iptables -I INPUT -p tcp --dport 10000 -j ACCEPT

That might conflict with firewalld (if you’re using it instead of iptables to manage your firewall), so you may need to figure out what’s managing your firewall.

That was the issue… Which is weird why it was working then suddenly stopped. Thank you so much for your help as its greatly appreciated!