Admin / database password becoming invalid


I’m running the latest Virtualmin / Webmin versions, on a CentOS 7 VPS. I have 6 website accounts set up, all running Wordpress sites, all set up the same way, and all but one of them are working without issues.

Seemingly without cause, one of the sites, set up the same way as the rest, will show an “error connecting to the database” Wordpress error. The only way I’ve found to resolve this is to change the admin password for the account to something else, which is what the mariadb / mysql database is set to use, and then change it back. Trying to change it to the same password doesn’t work, I have to change it to a different one first and then back. I’ve tried a couple different passwords, but it seems like the password itself doesn’t make any difference to the problem.

There doesn’t seem to be any logic to when the password will stop working, I’ve had it go weeks without issues, and then I’ve had it happen twice in two days. I’ve not tried logging in to the usermin section with the admin username and password when this happens, because I’ve been more concerned with getting the site back up.

I have tried logging into mariadb, but it seems like it won’t accept any usernames or passwords at all, so I’m not able to check whether it considers that one specific password as invalid. Restarting the service doesn’t change anything.

Before I start creating different users specifically for the database and try to see if the same thing happens, does anyone have any idea why this would be occurring? I haven’t seen any logs that have been of any use. I’ve had a quick search on the internet and haven’t seen anything similar.

Thanks for your time.