adding sub-server subdomains to parent server zone

Hi, I just read this:

I have 3.68 installed, and I just tried it as described. I have, correctly set up, and I add, as a sub-server of Virtualmin creates a new file in the bind masters directory. It would be better if it created a
blah CNAME
record, (and perhaps www.blah CNAME), in the directory.

Apparently, this is what’s supposed to happen, but it didn’t. I’m wondering if it’s something to do with having the template set up wrong: in Server templates>Defaults for Sub-servers>Bind DNS domain, the setting for “Add sub-domain DNS records to parent domain?:” is set to “Use default settings” and is greyed out, so I can’t change it, and I can’t figure out a way to make it not-greyed out. I assume the “default” it refers to is in the main default server template - this has the same option, and it is set to “No”, and also greyed out, so I can’t change it.

Any idea how I can get this working?

sorry for the double post :confused:

You do have to have that option (“Add sub-domain DNS records to parent domain?”) set to yes. I’m not sure why it would be unavailable in the Default Server Template. Are you logged in as root?

Being root wasn’t the problem.

The option is apparently only available if the “Add SPF DNS record?” is set to “Yes, with server’s IP address”. I wouldn’t have guessed this, I just tried poking around. Would it be possible to either a) add a note about that in the docs for the “Add sub-domain DNS records to parent domain” option, or remove that requirement? (While it’s nice for people to include SPF records, they probably shouldn’t be FORCED to :))

Ok, so I set SPF records on, and "add subdomains to parent zone" on for the master template, and left "use defaults" on for both options in the sub-server template.

I tried adding a domain "bindtest.argh"

Firstly, problem one: SPF record not created in master zone. no biggie, we usually just add it to out custom zone template anyway. (is the fact this is a custom zone template the problem?)

Problem two: added a sub domain, "sub.bindtest.argh", and got this message:
"Adding records to DNS zone bindtest.argh …
… done"

Sounds nice, but it didn’t do anything. there is no new hosts file (good), but there also isn’t any new CNAME or A records.

Where to from here?

Bug! File a ticket in the bug tracker. That’s what it’s for. :wink:

Two bugs: one for each problem… not sure how severe these are, and not sure if one is even a bug - might be by design…

Excellent. Good bug reporting skills. :wink:

And, I note that Jamie has fixed both problems in the next release (3.69 is probably about a week away).

Same here. I posted a solution that worked for me at:

Search for the comment posted on June 26, 2009 and titled “Solution - Edit sub-server template”.